Jump to content
christiandard

Blueprint point lumineux

Recommended Posts

Bonsoir.

Je me lance dans l'édition de blueprint en essayant un point lumineux.

J'édite mon Blueprint, je l'exporte , tout fonctionne sauf que je ne trouve pas la référence dans le jeu.

Pourtant dans le preview du BlueprintEditor, il est visible.

Qu'est ce que j'ai râté ou zappé ?

 

RW01.jpg

Share this post


Link to post
Share on other sites
anoel    64

christiandard,

En fait là tu as créé un point lumineux omnidirectionnel de type "Point Light"

Ce point lumineux doit ensuite être utilisé comme "Children" dans le blueprint de par exemple un lampadaire.

Je conseille par ailleurs de créer un répertoire "Light" dans lequel toutes les créations de points lumineux seront regroupées.

A. Noël

Exemple de structure :

image.png.e4470e8eb60cc239d06c784f32720639.png

 

Share this post


Link to post
Share on other sites
pierreg    623

Bonjour Christiandard,

Une idée : dans ton blueprint tu ne montres pas la partie "BrowseInformation" or c'est dans cette partie que tu définis sous quel nom et dans quelle catégorie tu retrouveras ton objet sous l'éditeur...

De plus tu as coché "DayNight cycle" donc tu ne le verras que la nuit dans le jeu.

A+

PierreG

 

Share this post


Link to post
Share on other sites

Bonjour.

Merci pour vos réponses.

Anoel, j'ai repris votre Blueprint et j'ai comparé avec le mien, j'ai changé les lignes qui ne correspondait pas et j'ai maintenant mon point lumineux dans le jeux.

Mais je n'ai pas compris le pourquoi.

Je vais y regarder de plus près. Au fait la catégorie eMisc correspond à quoi ?

Je crois que c'est là que le bas blesse pour le voir dans l'éditeur de jeu.

Merci en core pour votre aide.

Ch  

Share this post


Link to post
Share on other sites
anoel    64

christiandard,

La catégorie eMisc correspond à 'Divers' dans les choix de l'éditeur.

A. Noël

 

Share this post


Link to post
Share on other sites

Anoel,

Pourrais-tu m'envoyer un Blueprint avec une lumière comme "children".

Je crois faire une erreur au niveau du nom et de l'ID.

Ch.

Share this post


Link to post
Share on other sites
Posted (edited)

Bonsoir.

Impossible de faire un association de mon point lumineux à mon lampadaire.

J'ai toujours une erreur dès que je veux mettre le lien, que j'essaie avec le chemin complet ou seulement "Lights".

Deux jours que je me casse la tête...

Pouvez-vous m'aider ?

 

Ch.

BPrint01.jpg

Edited by christiandard

Share this post


Link to post
Share on other sites
fildefer    414

Bonjour Christiandard.

Il faut développer Blueprint set ID pour y inscrire ton nom de Provider (Créateur) et Product (le sous répertoire de provider où se trouve ta création). Pour toi: Provider=Cricri et Product= Scenery.

Amitiés

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour.

Merci "fildefer", ça fonctionne, merci pour ton aide.

En fait, je peux voir le résultat dans l'éditeur Blueprint, dans l'éditeur de jeu j'ai la référence mais l'objet n'apparaît pas quand je veux le placer.

Pourtant à l'export, tout est ok, je ne comprends pas....

Qu'est ce que j'ai encore râté ?

Ch.

Edited by christiandard

Share this post


Link to post
Share on other sites
anoel    64

christiandard,

Je vois qu'il y a évolution dans la création pour TS.

Lors de la création dans le logiciel de modélisation, il est INDISPENSABLE de générer au moins un niveau de LOD (Level Of Detail)

Donc l'objet fini doit ABSOLUMENT commencer par (par exemple) 1_0100_blabla(minuscules)

Ce qui signifie que cet objet sera visible à partir d'une distance de 100 mètres.

Je répète lorsqu'il y a un problème, c'est toujours le fichier .igs qui est en cause; même si la compil est ok.

Par ailleurs je conseille fortement lorsque tes projets vont se multiplier de tout de suite bien appliquer une structure de répertoires et fichiers (voir par exemple dans Kuju)

Les "lights" c'est une chose, les objets c'en est une autre (Ex. : Divers ou Luminaires) Par exemple l'éclairage d'une voiture voyageur pourrait aussi aller chercher le pont light d'un luminaire pcq celui-ci convient.

Je sais c'est contraignant mais il faut pour ainsi dire une discipline de création.

A. Noël

 

Share this post


Link to post
Share on other sites

Anoel,

Si je comprends bien c'est mon luminaire qui doit s'appeler, dans Blender 1_0100_Luminaire et ma sphère pour le point lumineux 1_0100_lampe ?

Ce que je voudrais comprendre, c'est pourquoi en objet simple, on ne doit rien mentionner par exemple pour mes gares et maisons que j'ai déjà placé dans le jeu.

Je vais essayer cela tout à l'heure.

Merci pour les conseils et les remarques, j’apprends doucement sans brûler les étapes parce-que c'est compliqué quand même ces blueprints...

Mes neurones se réveillent peu à peu.

Ch. 

Share this post


Link to post
Share on other sites
anoel    64

christiandard,

Oui c'est implicite. c'est contenu dans l'igs mais n'apparait nullement dans le simulateur.

Par contre si c'est des gares et des maisons à partir de tes propres .igs là normalement cela ne devrait pas fonctionner ?

! Il y a un L majuscule dans Luminaire. Je crois que les minuscules sont requises (j'ai dû le lire il y a longtemps !)

C'est pas trop les blueprint qui sont complexes mais bien la rigueur de création des modèles. Il n'y a aucun droit à l'erreur ou omission.

A. Noël

 

Share this post


Link to post
Share on other sites
Posted (edited)

Bonsoir.

Grâce à vos conseils, j'ai exporté mon lampadaire avec la source lumineuse.

Dans l'éditeur blueprint (prévieuw), je peux placer la source lumineuse à l'endroit voulu, en fait je peux la déplacer car elle reste un objet différent du luminaire.

Dans l'éditeur du jeux la source lumineuse est collée au pied de mon lampadaire et je ne peux pas la bouger, c'est normal du fait qu'elle fait partie intégrante du modèle.

Comment faire pour la placer au bon endroit ? J'ai lu que l'on peut l'employer dans l'éditeur d'assets, où se trouve-t'il ?

Dans la "matrix" aussi par exemple, à quoi correspondent les grilles et les chiffres ?

Ou autrement ?

Ch.

Edited by christiandard

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour.

En cherchant sur la toile, j'ai trouvé comment placer mon point lumineux avec la "Matrix" et les cases correspondantes (4,8,12).

Merci pour votre aide, je continue mon apprentissage....

Ch.

RW04.jpg

20180522121745_1.jpg

Edited by christiandard

Share this post


Link to post
Share on other sites
anoel    64

christiandard,

En fait l'utilisation d'un "children" dans un objet parent entraine quasi systématiquement le placement à l'aide le la matrice.

Pour certain cas d'inclinaison de lumière pour des locos par exemple, il faut faire du calcul matriciel ... Bon d'accord j'ai écrit un guide pour cela.

Le voici en en pièce jointe.

Attention, dans la matrice il faut utiliser des virgules et les 'moins' ne s'écrivent pas avec le (-) du pavé num mais bien avec la touche du clavier (underscore et moins)

Également lors de l'information de la matrice on introduit de beaux chiffres ronds. Le moindre mouvement dans l'asset editor (d'ailleurs très délicat et déconseillé) entraine vite des chiffres peu utiles.

Avec TS il n'y a rien de simple d'où la rareté des créations !

A. Noël

 

BPE 2 _ Création de Blueprint_Informer une matrice.zip

Share this post


Link to post
Share on other sites
Posted (edited)

RE...

En voyant la matrice, voici les valeurs que j'ai dû rentrer pour placer mon point light :

Le X correspond, mais la valeur Y correspond au Z.

Il y a donc certainement quelque chose que j'ai mal paramétré dans Blender ou autre ?

RW05.jpg

 

Ch.

Edited by christiandard

Share this post


Link to post
Share on other sites

Bonsoir.

J'ai compris le système avec les axes dans la matrice.

Après avoir relu un des tutos d'Anoël, les axes dans TS ne sont pas les mêmes que dans un programme 3D.

Autant pour moi !

 

Ch.

Share this post


Link to post
Share on other sites

×