Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal

Search the Community

Showing results for tags 'non-function: Update'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Liens
    • Règles du forum
    • Lien : site officiel de Railworks
    • Zone de téléchargement et d'upload
    • Lien : Wikirail
    • [FAQ] Foire aux questions
  • Généralités
    • Présentations
  • Train Sim World (2)
    • Discussions Générales - TSW 2020 & TSW 2
    • Captures d'écran et vidéos
    • Technique et Cie.
    • Add-ons et utilitaires
  • Train Simulator 2020
    • Discussions générales - TS 2020
    • Captures d'écran et vidéos
    • Technique et Cie.
    • Création de matériel roulant
    • Création de lignes
    • Création de scénarios
    • Création de décors et autres objets.
    • Add-ons et utilitaires
    • English Forum
  • Discussions
    • Le bistrot de la gare
    • Chemins de fer réels
    • Photos / Vidéos
  • Autres Simulateurs
    • Les autres simulateurs
  • Divers
    • Microsoft Train Simulator 2

Categories

  • Matériel Roulant
    • Locomotives diesels et électriques
    • Locomotives à vapeur
    • Automotrices et TGV
    • Wagons de Marchandises
    • Voitures Voyageurs
    • Reskins
    • Images PreLoad
    • Patchs correctifs
  • Objets
    • Gares
    • Caténaires
    • Décors de voie et bâtiments ferroviaires
    • Décors non ferroviaires
    • Ouvrages d'art
    • Signalisation
    • Sons
  • Outils
    • Tutoriels
    • Plans
    • Utilitaires
  • Scénarios
    • Quickdrive
    • Allemagne
    • France
    • Royaume Uni
    • Autre pays
  • Lignes
    • Françaises
    • Etrangères
    • Belges
  • UKTS Freeware Packs

Found 1 result

  1. Bonsoir à tous, En ce moment je m'essaye au scripting d'un train rien de bien folichon un boxe avec un essieu simplifié sans cabine et vue passager. Mais je rencontre un problème dont je n'arrive pas à m'en débarrassé. - Une fois le script crée généré au blueprint editor, un script qui est une coquille vide, le Logmate me spam avec 3 erreur qui rendent impossible la bonne tenue du script. Trace cScriptState.cpp : 165 = Unable to execute non-function: Setup Trace cScriptComponent.cpp : 464 = Failed to push function Setup onto stack: Trace cScriptState.cpp : 165 = Unable to execute non-function: Initialise Trace cScriptState.cpp : 165 = Unable to execute non-function: Update Trace cScriptComponent.cpp : 464 = Failed to push function Update onto stack: hors ces fonctions ("function") sont bien présentent dans le script ci dessous: DEBUG = true function Initialise () Call("BeginUpdate") end function Setup () end function Update (time) end function OnControlValueChange (name, index, value) if Call( "*:ControlExists", name, index ) then Call( "*:SetControlValue", name, index, value ); end end function OnCustomSignalMessage ( arg ) end function OnConsistMessage ( message, arg, direction ) DebugPrint ( ( "DEBUG: OnConsistMessage msg:" .. message .. ", arg:" .. arg .. ", dir" .. direction ) ) end function DebugPrint( message ) if (DEBUG) then Print( message ) end end Là j'ai besoin d'éclaircissement car je suis arrivé à un vrai blocage. Merci de votre aide. Amicalement zkiko.
×