Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
cerbere22

Train Simulator 2019

Recommended Posts

Gandalf    1,582

Ah au fait, n'oubliez pas que pour l'astuce que j'ai donnée avec la modif dans la registry pour passer Railworks.exe en priorité haute à l'exécution, il faut refaire la même manip avec Railworks64.exe du coup ..... Je trouvais qu'il micro-saccadait plus que le 32, j'ai vite compris pourquoi :-)

Share this post


Link to post
Share on other sites
Gabtrain94    33

Bonsoir à tous,

j'ai pris contact avec Christrains et il m'a envoyé un nouveau patch pour son matériel car celui sur son site était non fonctionnel, je viens de lui confirmer que celui-ci fonctionnait, voila je vous donne le lien pour ceux qui possède son matériel roulant

Amitié

Patch Chistrains pour TS 19 /64 bits :  http://www.christrains.com/patches/ChrisTrains_TS2019_LicensePatch.exe

Edited by Gabtrain94
  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
volcano182    261
Il y a 10 heures, blindos a dit :

Pour Volcano182 c'est l'extension Berlin-Leipzig "Mighty Seddin Freight" et concernant les FPS bas dans quelques endroit chargés ou cela rame presque genre diaporama, au dessus de 25 c'est fluide donc pour moi c'est bon.

A+

merci

Share this post


Link to post
Share on other sites
pierreg    1,255

Bonjour à tous,

En lisant vos comptes-rendus du passage à TS2019, je me suis laissé tenter alors que je suis souvent réticent à changer de version trop rapidement.
Et en fait, j'ai eu beaucoup de mal, car après un téléchargement d'environ 100Mo, rien ne se lançait et il m'a fallu faire plusieurs vérifications de fichiers mais avec le même résultat : TS2019 se lançant mais n'affichant plus rien après le "splashscreen" 600x200 de démarrage (aussi bien en 32 qu'en 64 et alors que le processus était toujours actif).
C'est quand même surprenant d'ailleurs de se retrouver dans cette situation et c'est plutôt STEAM que j'incrimine si ses protocoles de téléchargement et de vérification sont capables d'oublier des fichiers ou de mal les télécharger....

Et n'ayant finalement aucun résultat, j'ai décidé de faire une réinstallation complète du noyau TS2019: ça marche  mais dès le départ j'ai rencontré des nouveaux bugs, alors que je n'avais plus de plantage depuis longtemps sous TS2018 :
- "Access violation" (qui crashe aussi Steam!!), le plus souvent en mode 64bits lors d'une édition de ligne ou de scénario,
- crash de TS et de Steam simultanément sans rien dire...
- "Access violation" avec le message "missing MSVCP100D.dll" en général au lancement d'un scénario....

Tout ceci sur des lignes et des scénarios qui fonctionnaient normalement sous TS2018.

Donc je regrette globalement ce passage trop rapide à TS2019 qui ne m'apporte pour l'instant que des plantages supplémentaires!! :angry:

Bon jeu quand même,
PierreG

config : Intel Core i3-3220 CPU 3.30GHz - RAM 8Gb - NVidia GeForce GTX650Ti 4 Gb
Windows7 Home Edition 64bits SP1

  • Like 1
  • Thanks 1
  • Sad 4

Share this post


Link to post
Share on other sites
zawal    3,320
il y a 47 minutes, pierreg a dit :

Bonjour à tous,

En lisant vos comptes-rendus du passage à TS2019, je me suis laissé tenter alors que je suis souvent réticent à changer de version trop rapidement.
Et en fait, j'ai eu beaucoup de mal, car après un téléchargement d'environ 100Mo, rien ne se lançait et il m'a fallu faire plusieurs vérifications de fichiers mais avec le même résultat : TS2019 se lançant mais n'affichant plus rien après le "splashscreen" 600x200 de démarrage (aussi bien en 32 qu'en 64 et alors que le processus était toujours actif).
C'est quand même surprenant d'ailleurs de se retrouver dans cette situation et c'est plutôt STEAM que j'incrimine si ses protocoles de téléchargement et de vérification sont capables d'oublier des fichiers ou de mal les télécharger....

Et n'ayant finalement aucun résultat, j'ai décidé de faire une réinstallation complète du noyau TS2019: ça marche  mais dès le départ j'ai rencontré des nouveaux bugs, alors que je n'avais plus de plantage depuis longtemps sous TS2018 :
- "Access violation" (qui crashe aussi Steam!!), le plus souvent en mode 64bits lors d'une édition de ligne ou de scénario,
- crash de TS et de Steam simultanément sans rien dire...
- "Access violation" avec le message "missing MSVCP100D.dll" en général au lancement d'un scénario....

Tout ceci sur des lignes et des scénarios qui fonctionnaient normalement sous TS2018.

Donc je regrette globalement ce passage trop rapide à TS2019 qui ne m'apporte pour l'instant que des plantages supplémentaires!! :angry:

Bon jeu quand même,
PierreG

config : Intel Core i3-3220 CPU 3.30GHz - RAM 8Gb - NVidia GeForce GTX650Ti 4 Gb
Windows7 Home Edition 64bits SP1

J'ai exactement la même chose que toi .

Imagine les MSV ( tien c'est marrant ça remplace les dump fil ) sans raison en plein boulot !!! 

Comme dirait machin dans les bronzés : " nul sale zéro " DTG c'est des gros noob 

Depuis 3 h j'en suis déjà à 4 MSV et je bosse sur ma ligne au US , c'est vraiment la misère .

Je rajoute que si jamais je passe de 32 à 64 entre deux extinction de TS , tout mes signiaux posé ne fonctionne plus !! 

 

  • Sad 2

Share this post


Link to post
Share on other sites
laissele    31

salut

j'ai eu la mème chose, donc j'ai chercher sur le net et copier le MSVCP100D.dll dans windoze system 32 et sysWOW64 et ça ne plante plus pour l'instant

bon jeu

Edited by laissele

Share this post


Link to post
Share on other sites
Flash_2013    1,347

Salut,

Vous n'êtes pas les seuls sue le coup!
Rien ne démarrait... J'ai du effacer le dossier 'Railworks' complet, tout réinstaller, et m'y prendre à 3 fois pour apparemment tout récupérer.
La version 32 bits fonctionne, mais seulement en 1920x1200. Quant'au 64 bits, il ne démarre pas et fige la machine, quelque soit la résolution choisie (sur un écran ou 2 écrans). je suis forcé d'éteindre et rallumé. Suis dégouté...

NB. A l'heure actuelle même le 32 bits ne fonctionne plus… souris figée et coupure totale de l'ordi! Merci DTG; suis bien tenté de mettre tout ça à la poubelle… quel gâchis!

 

  • Sad 1

Share this post


Link to post
Share on other sites
toto13015    655

Salut,

Mes nodes pour les passagers ne fonctionne plus aussi, pour l'AGC V4 et pourtant cela fonctionnait bien sous le 2018. Tout est fait comme Zkiko me l'avait dit mais rien n'y fait que ce soit 32 ou 64 bits. 

Refait à plusieurs reprise mais rien. 

toto13015 

Share this post


Link to post
Share on other sites
Simulateur    339

MSVCP100d.dll est une bibliothèque de débogage, la version « utilisateur final » d'un programme ne devrait pas tenter d'y recourir. Il y a donc (qui pense « encore » ?) quelque chose qui cloche dans la version 2019 de TS...

Share this post


Link to post
Share on other sites
oliver27    21

Il y a effectivement un gros problème de FPS avec la version 64 bits, j'ai fait 4 tests comparatifs, mêmes réglages, même scénario (FXAA+8xMSAA, anisotropique x8), curseurs de réglages 1 cran avant la position maximale, cela me donne (je joue généralement en tri-écran):

Scénario AP36 1A65 sur la ECML London-Peterborough, depuis le départ du scénario et environ 3 minutes de jeu:

32 bits, résolution 5760x1080 (tri-écran), moyenne de 47 FPS

64 bits, résolution 5760x1080 (tri-écran), moyenne de 13 FPS

32 bits, résolution 1920x1080 (1 écran), moyenne de 52 FPS

64 bits, résolution 1920x1080 (1 écran), moyenne de 20 FPS

Ordinateur neuf, carte-mère ASUS Z370F-Gaming, CPU I5-8600K non overclocké, GTX1080 avec dernière version des drivers, système sur un SSD Samsung 860 EVO et TS2019 sur un SSD Samsung 850 EVO.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
sthubertal    226

Bonjour à tous,

J'arrive sur ce forum, et  je rejoins hélas le flot de ceux qui pour l'instant aurait souhaité resté sur l'ancienne version.

Tout comme Pierreg, je n'aime pas trop la rapidité dans ce domaine. En ce qui mon concerne, le méga projet Rhône Alpes Maurienne sur lequel je travaille (Merci Pierre pour ton aide),

ne fait pas bon ménage avec cette version, j'ai maintenant des coupures , le fps n'est pas meilleur, voire moins bon, des blocages que je n'avais pas apparaissent,

et sont très difficiles à localiser et corriger par contournement du problème. Je peux dire que je suis déçu, et démarrer le jeu en 32bit maintenant ne résout pas les problèmes. J'aurais dû copier l'intégralité du dossier Steam

avant. Pour tous ceux qui souhaitent éviter cette version, y a t'il une méthode pour ne pas qu'elle s'installe automatiquement, je leurs conseillerais plutôt..

Cordialement,

Alain :)

 

Edited by sthubertal

Share this post


Link to post
Share on other sites
gg90    3
Il y a 20 heures, Gandalf a dit :

Ah au fait, n'oubliez pas que pour l'astuce que j'ai donnée avec la modif dans la registry pour passer Railworks.exe en priorité haute à l'exécution, il faut refaire la même manip avec Railworks64.exe du coup ..... Je trouvais qu'il micro-saccadait plus que le 32, j'ai vite compris pourquoi :-)

Désolé Gandalf mais à quelle page puis je trouver cette modif :wacko:

par avance merci

  • Like 1

Share this post


Link to post
Share on other sites
loud06    103

bonsoir

loin de prendre la défense de Dovetail, mais il est normal qu'il  y ait des soucis avec cette nouvelle version, de même qu'il est normal qu'il ne soit pas optimisé à 100% (déjà qu'avec la version 32 bits c'était pas vraiment optimisé) mais ils ont du faire évoluer le moteur même du jeu, et informatiquement parlant, c'est normal... Par contre il faut qu'ils y remédient au plus vite, c'est sûr aussi.

Edited by loud06
  • Like 1

Share this post


Link to post
Share on other sites
sthubertal    226

Tout à fait, je ne cible pas négativement mes propos, mais d'une façon constructive pour les développeurs de TS. :)

 

Edited by sthubertal

Share this post


Link to post
Share on other sites
Simulateur    339

Deux précisions données par DTG_Luke (développeur) qui pourraient peut-être aider certains : 

• We're finding that for some people, their nvidia control panel is not seeing railworks46.exe as a game and is launching it using the integrated graphics options.
If you're experiencing severely low FPS in 64-bit, this may be the cause. We recommend you check your nvidia control panel.

• It also defaults back to opening 32-bit when the game asks to restart after clearing cache. 
We're working on a solution, but for the time being we recommend that when the game asks to restart, click No then restart it manually.

Share this post


Link to post
Share on other sites
cecel07    6

Voici un petit tuto pour changer la priorité d'un exécutable :

chez moi ça ne saccade plus B)

Share this post


Link to post
Share on other sites
loud06    103

Hello

quelqu'un a des news de train maps live sous 64 bits ?

merci

Share this post


Link to post
Share on other sites
ES64F4    2,046
Il y a 21 heures, cecel07 a dit :

Voici un petit tuto pour changer la priorité d'un exécutable :

chez moi ça ne saccade plus B)

Encore un comique qui ne comprend même pas ce qu'il fait. Premièrement, changer la priorité n'alloue pas plus de mémoire. Deuxièmement, cette modification ne porte que sur l'instance en cours. Donc quand on ferme le logiciel puis qu'on le relance, il ne garde pas ladite priorité en mémoire. Il faut faire un script qui une fois le logiciel lancé modifié le niveau de priorité sinon, c'est du pipo ou du placébo, au choix. D'autres approches que le script existent avec des modifications dans la registry. Dernière remarque, la modification de priorité par script (en CMD ou PowerShell) ne fonctionne pas de la même manière pour Windows 7, 8 et 10. Certains modes ne fonctionnent tout simplement plus avec Windows 10.

Merci à tous ces ploucs qui polluent le net avec des vidéos débiles de désinformation. :thumbdown3: Vu le niveau pitoyable de certains youtubeurs (qu'on devrait souvent appeler des youtebés), sachez une chose : si à la fin de leur pseudo tutos, ils ne démontrent pas explicitement le fonctionnement de ce qu'ils ont "démontré", c'est qu'ils en sont incapables et/ou parce que ça ne fonctionne pas.

Edited by ES64F4
  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites
Gandalf    1,582

Un peu violent sur la forme, mais sur le fond, c'est ça.... et donc pour Win 10, vu qu'ici en tout cas ça ne marchait plus trop via script ->

Et même chose pour Railworks64.exe du coup, donc 2 clés à créer.

Share this post


Link to post
Share on other sites
Simulateur    339

Je ne sais pas ce que ça donne lorsque c'est défini dans le registre, mais via un script, j'ai dû séparer le lancement du programme de l'attribution de priorité et rajouter un sleep d'une demi-seconde, sinon ça ne fonctionne plus - avec la version 64-bit en tout cas (peut-être parce qu'ils ont rajouté une première fenêtre indiquant quelle version a été lancée, mais je ne vois pas pourquoi car aucun processus annexe n'apparaît dans le gestionnaire des tâches avant RailWorks64.exe).

Share this post


Link to post
Share on other sites
La grenouille    2,244
Dixit DTG ( traduction Google)
 
...."Nous constatons que, pour certaines personnes, leur panneau de configuration nvidia ne considère pas railworks 64.exe comme un jeu et le lance à l'aide des options graphiques intégrées.
Si vous rencontrez des FPS très bas en 64 bits, cela peut en être la cause. Nous vous recommandons de vérifier votre panneau de configuration nvidia.... mais encore?

• Il revient également à l'ouverture 32 bits lorsque le jeu demande de redémarrer après avoir effacé le cache.
Nous travaillons sur une solution, mais pour le moment, nous recommandons que lorsque le jeu demande à redémarrer, cliquez sur Non, puis redémarrez-le manuellement"....
.............................................................
Je note le "certaines personnes"....de même que certains colistiers du forum ne rencontrent aucun problème avec la version 64 bit ....C'est bien le plus troublant ...:(

Share this post


Link to post
Share on other sites
oliver27    21
Il y a 9 heures, Gandalf a dit :

Un peu violent sur la forme, mais sur le fond, c'est ça.... et donc pour Win 10, vu qu'ici en tout cas ça ne marchait plus trop via script ->

Et même chose pour Railworks64.exe du coup, donc 2 clés à créer.

Merci, je vais essayer ça en attendant que DTG nous sorte un correctif. En modifiant manuellement la priorité via le processeur de tâche, je gagne quelques FPS (ça passe de 13 à 20 en tri-écran) mais cela reste bien en dessous de la version 32 bits.

J'ai vu des discussions dans des groupes facebook anglais que des possesseurs de CPU AMD Ryzen ont vu une amélioration des performances via la version 64 bits alors que ceux équipés de CPU Intel ont plutôt droit à de fortes baisses.

Edited by oliver27

Share this post


Link to post
Share on other sites

×