Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
pml3

2D2-9100 la reine de l'artère impériale

Recommended Posts

pml3    223

Bien que encore loin du but, voici un aperçu du modèle que je souhaite ajouter au jeu.

 

Pas rapide, j'en suis à 6 mois de modélisation <_<

 

Le modèle sera lourd, car je ne suis pas champion de l'optimisation (je dépasse 80000 poly !)

 

Aujourd'hui, le lod1 est quasi terminé.

 

Ca donne ceci :

 

Image IPB

 

Image IPB

Image IPB

 

 

Mais j'attaque maintenant les choses sérieuse : blueprint pour intégrer la loco tel quel dans le jeu.

 

Hard :angry:

 

1er résultat un peu cata !

 

Image IPB

 

 

pourtant je crois avoir respecté l'axe y pour l'axe du modèle.....

 

De toutes façon, je me donne jusqu'à la fin de l'année pour boucler car, il reste à faire :

 

1-le lod2

2-le lod3 (pas trop compliqué)

3-la cabine : là c'est un modèle complet en soi... et j'ai quatre photos !

Ca sera le plus dur.

 

Il reste un de ces boulot...

:wacko:

 

A suivre....

Share this post


Link to post
Share on other sites
pierreg    2,138

Bonsoir,

 

Voilà une trés bonne nouvelle ! Elle est belle, complète et dans le jeu donc :rolleyes: un très grand pas est fait. Ce qui t'arrive ne vient pas forcément du modèle :unsure:

C'est un problème déjà rencontré et qui peut venir des "blueprints" si la déclaration des Axes de bogies et d'essieux n'est pas strictement faite dans l'ordre "de l'avant vers l'arrière" dans les blueprints Engine (rubriques Bogey) et Bogies (rubriques Axle).

Néanmoins il faut aussi vérifier l'orientation du repère du corps du modèle dans le modeleur 3D.

 

Bravo en tout cas et bon courage pour la suite de ton superbe projet !

 

A+

 

PierreG

 

Share this post


Link to post
Share on other sites
pml3    223

Merci Pierreg !

Effectivement, le probleme était dans blueprint :angry:

 

J'ai supprimé la déclaration du bogie2 !

mais j'ai 2 bogies dans l'IGS...

 

Alors je ne suis pas sûr que tout soit rêglé.

Dans les docs, il y a une allusion sur l'instanciation possible des bogies.

On en mettrait qu'un dans l'IGS (économie notable) et grâce au blueprint, le jeu saurait généré les deux bogies.

Est-ce possible ?

 

en attendant, 2 images qu'elles sont chouettes :rolleyes:

 

sur les rails !

 

Image IPB

 

 

quand je pense qu'il y a trois mois, j'ignorais l'existence du bump-mapping !!!

 

Image IPB

 

sur l'avant, il y a un bleu-vert pas terrible à revoir.

 

A suivre.

Share this post


Link to post
Share on other sites
pierreg    2,138

Bonjour pml3,

 

Eh bien, chapeau si c'est le premier modèle pour RS que tu réalises :rolleyes: ! Il y a encore du boulot mais ça fait vraiment plaisir de voir ça.

 

Pour répondre à tes interrogations :

Oublies le principe de l'instanciation des bogies : c'est une erreur de la doc (elle en a pas mal) qui n'est pas à jour. Ils pensaient faire "à la Trainz" mais ont abandonné. Le modèle doit comporter tous ses bogies et ses essieux avec évidemment les bons noeuds de hiérarchie dans un seul fichier IGS.

 

Je me suis fait une 2D2 (pas aussi belle que la tienne :( !!) pour vérifier tout ça :

 

Image IPB

 

 

Comme tu le vois, il y a 3 blueprints "Bogie" car 3 groupes d'essieux (respecter l'ordre de référence "avant d'abord" dans le paragraphe "Bogey" de l' Engine blueprint) mais il n'y a de géométrie (dans l'IGS donc) que pour le premier et le troisième qui sont des vrais bogies.

Dans leurs blueprints tu devras déclarer le nom du noeud de la géométrie les représentant. Pour le deuxième (qui sont les 4 roues motrices) tu laisses la ligne "Geometry" vide mais les 4 paragraphes "Axles" comporteront les références, dans l'ordre, des noeuds des 4 essieux (sinon les roues ne tourneront pas).

 

J'ai vérifié : ça marche bien sauf que ça manque un peu de jeu latéral dans les courbes serrées :D !!

 

Encore bravo et bonne continuation pour ce beau projet !

 

A+

 

PierreG

 

Share this post


Link to post
Share on other sites
pml3    223

Salut Pierreg,

et merci de tes réponses. Elles éclaircissent ma lanterne !

mais bien sûr j'ai la question suivante :D

 

voici une image de mon blueprint. Il exige que les textures soit directement dans le sous-répertoire "Engine"

alors que dans 3dsmax, je les ai mises dans "engine\textures".

 

Image IPB

 

 

et même si je change le répertoire déclaré dans les matériaux de 3D, rien n'y fait, toujours la mm erreur.

Je n'arrive à un export dans blueprint qu'en mettant effectivement les textures dans \engine :angry:

 

Une idée ?

Share this post


Link to post
Share on other sites
pierreg    2,138

Bonsoir Pml3,

 

Je ne comprends pas bien ce que tu décris puisque tu as montré la loc sur ses rails :blink:. En principe quand l'Asset editor recherche les textures demandées par un fichier IGS, il cherche d'abord dans un sous-dossier "Textures" soit, au pire, dans le même dossier que celui de la géométrie .IGS.

Crée d'abord un répertoire "Textures" dans le répertoire "Engine" et place les textures en question dedans. D'ailleurs j'ai remarqué que tes objets "Scenery" avaient parfois des textures placées bizarrement (et pourtant ça marche!! :) ) : par exemple des sous-dossiers dans le dossier "Textures" placé au même niveau que "Scenery", etc...

Pour une hiérarchie dans les règles, regardes les blueprints du Sample_engine fournis en exemple.

 

Si tu suis les règles de hiérarchie, tu devrais avoir au moins le chemin :

Source\pml3\Addon\RailVehicles\pml3_2D2_9100\...

ce qui dans les blueprints imposera les libellés Provider : pml3 et Product : Addon

Je ne suis pas sûr que tes problèmes viennent de là mais autant respecter les règles RS. De plus je te signale que dans l'"Object Filter" la présentation des noms de développeurs se fait dans l'ordre alphabétique mais Majuscules d'abord, puis minuscules. Donc avec "pml3" tu devras aller chercher tout au fond de la liste... :rolleyes:

Tu es sur la bonne voie. Bon courage et A+

PierreG

 

Share this post


Link to post
Share on other sites
Julien    569

Bonjour,

 

C'est curieux car, d'ordinaire, l'emplacement des textures est déterminée par l'emplacement relatif par rapport au fichier .max. Donc si tes textures sont placées dans un répertoire "textures" située lui même dans le répertoire de destination de ton fichier max, il ne devrait pas y'avoir de problème.

Share this post


Link to post
Share on other sites
zx42    10

Bonjour !

 

Tres belle réalisation ! Je voulais jute te dire que la machine que tu fais se trouve a Paris Lyon ( je pense que tu le savais ), donc si tu as besoin de photos ... Elle est là ;)

 

Bonne continuation !

 

Amicalement, Nicolas :)

Share this post


Link to post
Share on other sites
pml3    223

Salut PierreG

 

J'ai suivi tes conseils et modifié les chemins dans blueprint : c'est plus propre.

 

Ma loco parait sur les rails mais quand je mets un conducteur : déraillement instantané car en fait je suis "presque sur les rails" (décalage de qq cm)

 

Je crains que la cause soit le bazar dans le centre de gravité des bogies.

J'ai corrigé (affect pivot only, center to object, et reset transform que je ne connaissais pas.....)

 

et maintenant je ne vois mm plus la loco dans la preview d'asset !

Y a comme un creux là :angry: je suis perdu !

 

Je vais repartir du modèle de kuju et tout revoir... je trimbale des casseroles soit dans le modele, soit dans le blueprint, ou les deux...

 

A zx42,

la 9135 est à paris-Charolais, et mes textures s'inspirent directement de belles photos de cette machine,

trouvé sur internet. Quant à entrer dans l'enceinte du dépôt sncf.... et j'habite Villeurbanne !

 

Julien,

ta remarque va dans le sens de ma conclusion : tout remettre en ordre avant de poursuivre.

Edited by pml3

Share this post


Link to post
Share on other sites
pierreg    2,138

Bonjour à tous,

 

Ah, pml3, tu sais, j'avais intitulé un post "le cauchemar des blueprints"... Il y a eu des moments où j'ai failli faire tout passer par la fenêtre :lol:

Ma loco parait sur les rails mais quand je mets un conducteur : déraillement instantané car en fait je suis "presque sur les rails" (décalage de qq cm) Je crains que la cause soit le bazar dans le centre de gravité des bogies.

Je crois que le déraillement instantané peut avoir deux causes :

- la "Collision box" mal centrée avec une hauteur qui déborde sur les rails : elle doit être au-dessus des roues;

- une rubrique obligatoire manquante dans le Blueprint Engine. Malheureusement il n'est dit nulle part celles qui sont obligatoires. Par exemple "Driver Position" que tu dois placer en 3D dans l'Asset Editor, "Control Container component" avec toutes les "cab" et autres manettes, etc...

 

Si tu ne vois rien en Preview, cela peut venir d'erreurs de références vers les différents Bogey blueprints : attention aux champs Provider et Product à partir desquels RS reconstitue le chemin !

 

Une solution pour t'en sortir est bien de prendre le source du Sample Engine Electric de Kuju en le recopiant dans ta structure source et en modifiant les références vers ton modèle, ses paramètres et le reste restant par défaut.

 

Effectivement le décalage du repère modèle par rapport aux rails doit se régler dans le modeleur 3D. Moi je sais faire dans 3DCanvas mais pour 3DS Max ça ne devrait pas être très difficile. RS a l'air de se moquer totalement de ce genre d'erreur et des valeurs de Y dans les Bogey blueprints... C'est le repère modèle qui compte.

 

Bon courage,

 

PierreG

 

Share this post


Link to post
Share on other sites
pml3    223

Salut à tous !

 

le weekend a été bénéfique :D

J'ai éliminé mes casseroles, la loco fonctionne dans le jeu :D

 

En bref, et en suivant les conseils :

 

Je suis reparti du modèle de Kuju.

 

1- Donc refonte de mes répertoires.

-modèle sur C:\dev\railsim\source\Pml3\addon\railvehicles\Electric\pml3_2d2_9100\Default\engine (ouf!!!)

-résultat, c'est à dire fichier IGS sur le répertoire du jeu : K:\Rail Simulator\Source\Pml3\Addon\RailVehicles\Electric\pml3_2D2_9100\Default\Engine

-textures derrière \engine

 

2- Comparaison du blueprint du modèle de Kuju et du mien :

à priori, j'avais gardé les éléments de cabine sur le répertoire du modèle.

J'ai copié dans pml3, les éléments en question.

 

et ça va beaucoup mieux.

 

Je peux donc continuer.

Etape immédiate, ajouter les animations (panto et essuis glace) et tester sur le jeu.

 

A suivre.

 

Share this post


Link to post
Share on other sites
pml3    223

Et je continue :

 

Pantos et essui-glace ok

 

La loco au boulot dans Hagen.

 

Image IPB

 

Je suis bien moins avancé que Giovanni, j'attaque les lods, et je commence à réflechir à la cabine.

 

Julien, si tu as des "sons" de 2d2 dans tes archives (des sons de vielles électriques....) c'est le moment de m'en causer :)

 

A plus.

Share this post


Link to post
Share on other sites
Julien    569

Bonsoir,

 

Magnifique !

 

Pour les sons, il faut que je remette la main dessus. Ca ne doit pas être loin ;)

Share this post


Link to post
Share on other sites
pml3    223

News :) et questions forcement :angry:

 

1- Les lods sont prêts.

 

2- Je me suis penché sur les phares en partant du modèle de Kuju.

 

Les phares fonctionnent sans problême mais je n'arrive pas à fignoler ma texture pour obtenir le même résutat que sur les locos du jeu. explication par l'image :

 

Le jeu

Image IPB

 

moi :(

Image IPB

 

...pas pareil ! je cherche en vain le filtre de diffraction dans photoshop qui permet l'effet "étoilé"

si quelqu'un connait ?

 

D'autre part, j'ai essayé de simuler l'éclairage des phares sur la voie.

Voici qq images de mes essais.

 

de jour:

Image IPB

 

de nuit en hiver:

Image IPB

 

de nuit en automne

Image IPB

 

 

Comme ça, ca parait pas mal. Mais personne ne le fait.

J'ai peur que l'effet ne soit trop artificiel, et ne lasse...

Faut-il garder l'éclairage des phares sur le sol ? merci de vos avis.

 

3- pour finir : la numerotation auto des locos

j'ai fait, et ca numérote que dal !

Julien pourra peut être m'éclairer.

 

Mes paramètres :

-sur l'IGS :

un plane de 2 rectangles appelé 1_1000_primarydigits_2 (numérotation sur dizaine id2, et unité id1)

un multi-material avec 2 lignes, soit les 2 id, appelé "primarydigits":

1er appelé primarynumber_0 avec shader TrainBasicObjectDiffuse, slot1 : primarynumber_0_map(number_0.ace)

2eme appelé primarynumber_1 avec shader TrainBasicObjectDiffuse, slot1 : primarynumber_1_map(number_1.ace)

-sur blueprint :

je déclare mon fichier .csv (il sert à ça ?????) qui contient les nombres 01 à 35)

je déclare mon fichier ..2d2_digits.xml qui contient les textures number_0.ace à number_9.ace

 

résultat sur la loco : "10" affiché sur toutes les locos que je peux poser......

y a comme un défaut !

 

Voilà, c'est tout pour aujourd'hui.

En attendant vos remarques, je commence le plan de la cabine.

 

Patrick

 

 

Share this post


Link to post
Share on other sites
orangina75    83

Salut Patrick :)

Je trouve que ça vaut la peine de tester ton halo de lumière sur les voies, ça pourrait donner des idées à d'autres créateurs. Entre rien comme nous avons actuellement et ta solution, je préfère de très loin la seconde option. :)

Share this post


Link to post
Share on other sites
Julien    569

Bonjour Patrick,

 

Très élégante solution. Toutefois, c'était celle qui avait été retenue à l'origine par Kuju mais désactivée en dernier lieu car posant des problèmes d'alpha blending selon les textures et surfaces. As tu pu faire rouler ta bête sur une longue distance pour voir ce que cela donnait ?

 

A très bientôt

 

Julien

Share this post


Link to post
Share on other sites
pml3    223

Salut Orangina et Julien

 

J'ai fais un essai sur Hagen. Un simple roulage sur une quinzaine de km de nuit.

L'éclairage devant est ok.

L'essai s'est terminé par un déraillement dans un virage ! 144 tonnes à 180km:h, c'est pas vraiment dans les limites......... mais là, les phares éclairaient bien dans les buissons alentours.

juste remarqué qu'il faut une portée au moins de 2 longueurs de loco, et que de la cabine, il faut le prévoir pareil, sinon pas de phare derriere le pare-brise.

 

Julien, pas de remarques à propos des numeros de loco ?

 

A pare ça, je suis à fond sur la cabine. Ca avance.

 

Patrick

 

Share this post


Link to post
Share on other sites
Julien    569

Bonjour Patrick, je n'avais pas vu tes doléances à propos des numéros de locos ;).

 

Tout mon savoir provient de la doc et de ce lien (en anglais). Je te le poste au cas où : http://forums.uktrainsim.com/viewtopic.php...number#p1104293

 

Je suis désolé de ne pas être plus disert mais j'ai beaucoup de travail en ce moment, et pour couronner le tout, je déménage. Bref pas vraiment le temps pour RS et par ricochet, pas beaucoup de temps pour pondre des tutos et pour aider les courageux créateurs qui s'attaquent au "cauchemar des blueprints" (expression déposée par Pierre G)... Je m'en excuse.

 

A bientôt

 

Julien

Share this post


Link to post
Share on other sites
pml3    223

Bonjour Patrick, je n'avais pas vu tes doléances à propos des numéros de locos ;).

 

Tout mon savoir provient de la doc et de ce lien (en anglais). Je te le poste au cas où : http://forums.uktrainsim.com/viewtopic.php...number#p1104293

 

Je suis désolé de ne pas être plus disert mais j'ai beaucoup de travail en ce moment, et pour couronner le tout, je déménage. Bref pas vraiment le temps pour RS et par ricochet, pas beaucoup de temps pour pondre des tutos et pour aider les courageux créateurs qui s'attaquent au "cauchemar des blueprints" (expression déposée par Pierre G)... Je m'en excuse.

 

A bientôt

 

Julien

Merci pour le lien Julien, je vais regarder ça.

Je t'embète encore :) à propos des "bruits" des 2D2, voir d'autres motrices électriques anciennes.

Si tu as, ou si tu sais ou chercher, ça ne vas pas tarder de m'intéresser !

 

Bon courage pour le cirque domestique que tu as en cours ;)

 

La cabine avance :

modélisation : 80 %, textures : 60 %

identification des commandes....... j'espère 90 % !!! pas évident car ma doc se limite au livre sur les 2D2 de Denis Redoutey : 1 page et 3 photos sur la description de la cabine ...

Dans le simu, en mode facile, ca ira très bien, mais pour faire un mode expert correct, faut potasser ce livre en entier.

J'espère quand même arriver à une cabine potable.

Je mettrais une photo quand le texturage ressemblera à quelque chose pour Orangina qui a bien amélioré son avatard :lol:

 

A plus, Patrick

Share this post


Link to post
Share on other sites
pml3    223

Bonsoir à tous,

 

Orangina, comme promis, une photo du chantier de la cabine : c'est de la loco à l'ancienne :)

 

C'est pas encore fignolé, mais ça donne une idée :

 

Image IPB

 

 

 

 

.... et la question du jour, peut être pour Giovanni71 qui est avancé dans sa cabine....

ma caméra de cabine est bien placé sur le conducteur, à hauteur des yeux.

Si je fais un coup de flèche-droite, la caméra balaie vers la droite. Sauf que moi, en plus elle avance de 50 cm.

pourquoi ? :angry:

Quel code type de caméra mettez-vous dans blueprint ?

 

MM question pour la caméra extérieur...

 

A plus

Patrick

 

Edited by pml3

Share this post


Link to post
Share on other sites
pml3    223

Bonsoir à tous,

 

La cabine avance : le mode StopGo est presque fini.

 

Je commence à draguer les quais de la gare de la Part Dieu à Lyon pour enregistrer quelques chahuts des BB de passage. A partir de ces échantillons, et des commentaires trouvés sur le livre de Redoutey, j'inventerais les sons d'une 2D2 à peu près plausible.

 

Julien, tu m'avais parlé de qq exemples de sons de 2D2 ?

 

....puis les joies du blueprint....

 

et je finirais peu être à réussir une beta.

C'est quand même le but.

 

Patrick

 

Share this post


Link to post
Share on other sites
orangina75    83

Sympa ce projet. :) Tu passes beaucoup de temps chaque semaine pour le faire aboutir ?

Share this post


Link to post
Share on other sites

×