Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
Franck22000

RW Enhancer | Addon d'amélioration graphique pour TS20XX

Recommended Posts

zawal    3,319
Il y a 12 heures, Franck22000 a dit :

En tout cas quand je vois le dernier DLC de TSW (j'aime bien TSW mais il me manque le niveau de détails des lignes sur TS) et bien je me dit que je peux sortir quelque chose de tout à fait potable :)

TSW est franchement super immersif mais le manque de " détailles " casse un peut l'ambiance " réel " qu'il procure .

 Quand l'éditeur arrivera , je vais regarder ce que je peut faire pour " améliorer les lignes voir en faire une si c'est pas trop l'usine à gaz .:ph34r:

 

Sur TS ça fait depuis 2012 que je crée des lignes donc je connait très très bien l'éditeur ( d'ou ma rapidité en création ) 25 lignes à mon actif et toutes gratos , pas mal et j'en fait encore une en ce moment même !

Pour TSW il faudra que je reparte à zéro et ça va prendre un peut de temps vue que rien n'est pareil .

Mais bon , il n'y a rien qui n'est pas faisable , je verrais au fil du temps :D

 

PS: tu passe d'arma à TS !!! et tu aime le jeu ( la conduite de train ) ou c'est juste pour le taf ? 

RePS: GG pour arma , me suis bien éclaté dessus :wub:

  • Like 1

Share this post


Link to post
Share on other sites
Franck22000    324

J'aime vraiment le jeu ahah J'ai commencé avec MSTS et j'ai acheté railworks (la premiere version de kuju) dès qu'il est sorti (quece que c'était mauvais dans mes souvenirs à sa sortie :D).

J'aime les simus en general mais Train simulator c'est mon occupation principale quand je ne travaille pas :)

J'ai vu ton travail sur les lignes (je suis sur le forum depuis plus de 8 ans enfaite mais je restais dans l'ombre) c'est très joli. Je ferais peut être du contenu pour TSW plus tard car je connais assez bien l'unreal engine 4 que j'ai utilisé dans le cadre de mon travail.

  • Like 1

Share this post


Link to post
Share on other sites
SKlouis    644

Bonjour,


je ne peux que féliciter ton travail, cependant pour ceux qui utilise briage ( exportateur de TS dans blender) ce mode est incompatible !


En effet la liste des shaders ne peut plus être lue par briage ... 


Bonne journée 
Sklouis

Edited by SKlouis

Share this post


Link to post
Share on other sites
Franck22000    324
il y a 24 minutes, SKlouis a dit :

Bonjour,


je ne peux que féliciter ton travail, cependant pour ceux qui utilise briage ( exportateur de TS dans blender) ce mode est incompatible !


En effet la liste des shaders ne peut plus être lue par briage ... 


Bonne journée 
Sklouis

Bonjour, 

Comment à tu installé le mod ? a tu bien remplacé les shaders existant par ceux du mod ou alors a tu effacé tout les shaders originaux avant de mettre ceux du mod ?

A aucun moment il ne faut effacer un dossier ou un fichier dans le processus d'installation sinon tu va effacer des fichiers qui sont necessaires aux outils comme briage.

Edited by Franck22000
  • Like 1

Share this post


Link to post
Share on other sites
Franck22000    324

Hum c'est tres etrange. Briage produit t'il un message d'erreur ? 

 

Combien de fichiers sont présents dans ton dossier "shaders" actuellement ? 

Edited by Franck22000

Share this post


Link to post
Share on other sites
Franck22000    324

La solution temporaire pour le moment est d'utiliser le dossier de shaders originaux quand tu travaille sur blender... C'est vraiment bizarre en tout cas je te recontacterais quand je lancerais les phases de test de la prochaine version de cet addon.

Au niveau de mes progrès, j'ai recodé à 100% la fonctionnalité graphique "Bloom Adapatatif". Les resultat sont maintenant bien meilleurs et cela donne énormément plus de "volume" au niveau de l'éclairage.

Observez comment la lumière matinale du soleil "irradie" les potences de caténaires au premier plan :)

5bf56babca386_Railworks642018-11-2115-14-03-28.thumb.png.a2e9b435b6194ef62a4c036872a580ae.png

5bf56bf9e88f1_Railworks642018-11-2115-18-05-41.thumb.png.237560fb7cb7911be910f535bed1c4a1.png

Pareil pour les parties éclairée (par le soleil du matin) de cette cabine:

5bf56c48d0369_Railworks642018-11-2115-15-30-00.thumb.png.0bc6318ce3aac491975e67ecb6676da5.png

Et pour finir un petit détail mais la nouvelle gestion des reflets produit de jolis effets sur les roues des trains (quand les trains sont texturés correctement et pas à l'arrache) :) 

5bf56cc689ff2_Railworks642018-11-2115-17-43-21.thumb.png.544f216516706886cf1194e79d31bf8b.png

Mon travail continue ! 

Edited by Franck22000
  • Like 7

Share this post


Link to post
Share on other sites
Franck22000    324
il y a 4 minutes, nathcraft2 a dit :

Oh que c'est beau... :wub: Mais franchement ils foutent quoi dtg depuis tout ce temps?

Pas grand chose. Ma frustration est devenue trop grande alors du coup je suis passé à l'action :)

Je vais évidement assez vite car c'est des choses que j'ai déja codé dans le passé sur mes anciens projets donc forcement je vais assez vite :)

J'ai déja programmé des moteurs de jeux complets donc tout cela n'a plus vraiment de secrets pour moi :P

Edited by Franck22000

Share this post


Link to post
Share on other sites
oliver27    21

Excellent ton mod, j'étais en effet contraint de jouer à TS64 sans Reshade ou SweetFX car j'avais de grosses pertes de FPS (du style 15FPS en 64 bits alors que pas loin des 50 FPS en version 32 bits). Alors que je n'ai pas une petite config, i5-8600K et GTX1080 et je joue en tri-écran 5760*1080.

Pour les quelques minutes de tests que j'ai fait, ça me semble même meilleur graphiquement que SweetFX, c'est fluide et ça tourne au moins à 40 FPS.

Share this post


Link to post
Share on other sites
loud06    94

Merci Franck pour ton boulot. 

Question et demande abusive de ma part, mais c'est pas grave, je m'y risque : peux t-on faire quelque chose pour créer une vue comme l'équivalent de la touche "3" sur tsw mais sur ts 2019 ? d'après toi ?

merci encore

Share this post


Link to post
Share on other sites
jibeh    1,742
il y a 28 minutes, Franck22000 a dit :

Merci pour vos encouragement. Je suis en train de tenter quelque chose... Si je reussi... C'est la fin de TSW :P

Tu vas rendre le moteur du jeu multicore  ?  :P

Share this post


Link to post
Share on other sites
loud06    94

bon ben pas grave, merci pour ton boulot, ok pour te rémunérer, je pense que ts a encore de très très beau jours devant lui vs tsw, qui me déçoit, dlc après dlc... Manque l'éditeur, le matériel, le workshop, bref, beaucoup de choses..

Share this post


Link to post
Share on other sites
cbf78    2,960
Le 20/11/2018 à 07:53, La grenouille a dit :

Shaders avec SSAO installés .....> lancement de la scène ....>Glub's remontées gastriques dans le bocal ....> 2 CashSender 1403 exe _erreur d'application...

Devinez... j'ai réinstallé les originaux sauvegardés ....> Plus de souci....

Question: Que fait on des 4 fichiers commande (compil)...on supprime ou on garde ?

Bonjour

+1 meme problème Carte graphique GTX 1080 tous mes scenarios plantent comme la grenouille Marseilles Toulon inutilisable donc réinstallation de le sauvegarde des Shaders et tout refonctionne :ph34r: 

Share this post


Link to post
Share on other sites
cbf78    2,960
Il y a 8 heures, Franck22000 a dit :

C'est très etrange ça. Les deux versionne fonctionnent pas ? SSAO et normale ? 

Je ne sais pas je n'ai essayé que SSAO je retenterais la  normale;) je fait ça dans la journée et je te tiens au courant;)

Edited by cbf78

Share this post


Link to post
Share on other sites
cbf78    2,960

Salut Franck

Bon et bien après essais ce matin

1) lancement d'un scenarios au hazard sur la GEML avec la sauvegarde TS super nickel ce scenario fonctionne parfaitement ,essais d'autres scénarios sur d'autre lignes idem

2)Installation des shaders Normale ,lancement du meme scenario sur la GEML et je jeu plante au bout de 30 secondes :ph34r:re essais sur d'autres scénarios sur d'autres ligne idem

3) Réinstallation de la sauvegarde puis re essais comme plus haut  et tout refonctionne parfaitement :wub:

Amicalement

Share this post


Link to post
Share on other sites
Franck22000    324

Peut tu regarder après l'installation du pack de shader "normal" si le nombre de fichier contenu dans le dossier shader est identique par rapport aux shaders originaux ? 

 

Une capture d'écran de tes options de TS pourrait également aider :)

Edited by Franck22000

Share this post


Link to post
Share on other sites
cbf78    2,960

Oui apparemment il y' un soucis 

Fichiers orignaux 296

normal 130

 

20181122112831_1.jpg

Edited by cbf78

Share this post


Link to post
Share on other sites
al60    143
il y a 9 minutes, cbf78 a dit :

Oui apparemment il y' un soucis 

Fichiers orignaux 296

normal 130

bonjour,

Apparemment, à mon avis,  tu as supprimé les fichiers dans le dossier Shaders de TS pour les remplacer pas ceux de Franck alors qu'il ne faut pas supprimer les fichiers TS mais simplement faire le choix "remplacer" quand tu fais le transfert des fichiers.

Bonne journée

remp.JPG

Share this post


Link to post
Share on other sites

×