Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
  • Who's Online   1 Member, 0 Anonymous, 10 Guests (See full list)

  • Recently Browsing   0 members

    No registered users viewing this page.

JLD95

Freeware Photon66's LGV Nord Pas de Calais

Recommended Posts

jibeh    1,959

London-Faversham c'est la

00000034-c000-0000-0000-000000002013

l'as tu bien décompressée aussi, car c'est une "ap" également ?

 

La East Coast Main Line c'est

00000003-0000-0000-0000-000000000000

Share this post


Link to post
Share on other sites
Flash_2013    1,133

Salut,

Pour un itinéraire donné, apparait son dossier dans le dossier spécifique 'Routes'. Les itinéraires qui n'apparaissent pas avec RW_Tools sont en général 'compressés' dans un fichier de type *.ap (MainContent.ap...), dont DTG est particulièrement friand.

Pour que RW_Tools reconnaisse l'itinéraire inclus dans cette simili-archive, il suffit de la 'décompresser' à l'aide, soit d'un utilitaire de type '7zip' ou autre, soit RW_Tools par lui-même.

Il apparait alors des nouveaux dossiers (tels Scénarios, MixMap, networks...etc) et surtout le fichier 'RouteProperties.xml' qui 'déclenche' la reconnaissance de l'itinéraire par RW_Tools...

 

En résumé, pour maniper les itinéraires (route comme matériel...), cette décompression est indispensable, tout au moins en extraire ce fameux fichier 'RouteProperties.xml'.

Bonne journée...

Edited by Flash_2013

Share this post


Link to post
Share on other sites
cc72077    190

Il existe un utilitaire supplémentaire "RWInfo" qui lui liste le contenu de votre dossier Routes, en se moquant des .ap, et après la phase découverte, très utile pour voir les positions GPS, les Markers ...

Vous saurez exactement ce dont vous disposez. Parmi les autres petites lacunes de RWTools, une ligne sans scenario n'apparait pas.

Share this post


Link to post
Share on other sites
mayday2233    111

Merci pour vos réponses!

 

Effectivement il fallait décompresser le dossier MainContent.ap de la route en dehors de RW_tools.

 

Je l'ai décompressé avec '7Zip' dans le dossier routes de TS.

 

Pas évident comme prise en main ce RW_Tools! :)

Share this post


Link to post
Share on other sites
Gandalf    1,430

Merci pour vos réponses!

 

Effectivement il fallait décompresser le dossier MainContent.ap de la route en dehors de RW_tools.

 

Je l'ai décompressé avec '7Zip' dans le dossier routes de TS.

 

Pas évident comme prise en main ce RW_Tools! :)

 

C'est pour ça que j'ai fait un tutoriel qui détaille tout ça: http://www.railsim-fr.com/forum/index.php?showtopic=8071

Share this post


Link to post
Share on other sites
mayday2233    111

Bonjour,

 

J'ai créé un scénario quickdrive test entre paris gare du nord, lille europe et calais frethun pour tester les différentes saisons et les heures.

 

Le scénario ne comporte pas de trains AI.

 

j ai remarqué un gain de performance par rapport aux scénarios fournis avec la ligne.

 

scénarios fournis: entre 15 et 20 fps gare du nord , 20fps jusqu'à gonesse et entre 22 et 26 fps sur le reste de la lgv.

 

en quickdrive : 25 fps gare du nord et jusqu'à gonesse puis 30 fps sur la lgv.

 

je sais que les trains AI ont un impact mais il y en a très peu dans les scénarios fournis.

 

mes réglages graphiques:

 

résolution 3840#2160

FXAA + 8MSAA

VSYNC on

tous les détails au maximum sauf flore procédurale désactivée.

 

est ce que seuls les trains AI peuvent expliquer une telle différence ? au maximum une dizaine sur toute la ligne dans les scénarios.

Share this post


Link to post
Share on other sites
one1504    236

oui si les trains AI sont au même nombre de polys que les trains joueurs :)

 

en gros pour les trains AI il faudrait pouvoir utiliser des trains sans intérieurs de modélisé (autorails ou TGV pour cet exemple) moins gourmand en ressources :)

 

Edit: les rails 3D sont pas mal gourmands aussi mais je n'ai pas vérifié lesquels étaient utilisés dans cette ligne :)

Edited by one1504

Share this post


Link to post
Share on other sites
mayday2233    111

Bonjour,

 

Merci one 1504 pour ta réponse. :)

 

 

 

Je me demandais si beaucoup de monde utilisait la route et quelles sont vos impressions ?

  • Like 1

Share this post


Link to post
Share on other sites
Gandalf    1,430

Bonjour,

 

Merci one 1504 pour ta réponse. :)

 

 

 

Je me demandais si beaucoup de monde utilisait la route et quelles sont vos impressions ?

 

Me concernant, tout ce qui tourne entre 15 et 20 fps (et encore, je pense que l'affichage de fps du jeu indique 15 au plancher mais parfois ça tombe en-dessous), je passe mon chemin en attendant que sorte un fix... ou pas, tant pis.

Share this post


Link to post
Share on other sites
mayday2233    111

C'est vrai que c'est dommage qu'elle tourne si mal.

 

En quickdrive sans AI j'arrive à être entre 25 et 30fps, c'est déjà un peu mieux.

 

Par contre, as tu remarqué quand tu l'as testée qu'il n'y a quasiment pas de transition dans les pentes au niveau des voies?

 

Par exemple on passe brusquement de 0.0 à 11.1, en cabine ça créé une secousse pas très agréable.

Share this post


Link to post
Share on other sites
pierreg    945

Bonjour,

 

Comme dit plus haut dans le fil, après essais, je pense que la charge graphique n'est pas en cause mais plutôt des scripts qui occupent plus que nécessaire le CPU... :wacko:

Avec quelques trains AI, ça ne se passe pas trop mal: un train "joueur" casse le FPS.

Si quelqu'un de compétent sur le sujet pouvait regarder de plus près, c'est sûrement améliorable.

Sinon, réalisation assez impressionnante par ses dimensions.

Bon jeu,

PierreG

Edited by pierreg

Share this post


Link to post
Share on other sites
Gandalf    1,430

Oui c'est dommage le travail est énorme par ailleurs, si seulement ça ramait moins ça serait top.

Mayday, non je ne l'ai quasiment pas testée du coup, qques kms en sortant de la gare et exit :unsure:

Share this post


Link to post
Share on other sites
mayday2233    111

Question bête mais quand on parle de scripts sur une ligne, c'est en rapport avec les feux et la signalisation?

Par ailleurs j 'ai noté des incohérences sur les limites de vitesse dans l'HUD, parfois c'est en miles, parfois en km/h

Il doit me manquer 15 assets (que des sceneries), mais j ai tous les trackrules (qui proviennent de plusieurs lignes anglaises et allemandes), cela peut il expliquer ces incohérences?

Share this post


Link to post
Share on other sites
Gandalf    1,430

Question bête mais quand on parle de scripts sur une ligne, c'est en rapport avec les feux et la signalisation?

Par ailleurs j 'ai noté des incohérences sur les limites de vitesse dans l'HUD, parfois c'est en miles, parfois en km/h

Il doit me manquer 15 assets (que des sceneries), mais j ai tous les trackrules (qui proviennent de plusieurs lignes anglaises et allemandes), cela peut il expliquer ces incohérences?

 

Non, des assets de scenery ne vont rien changer aux limitations de vitesses posées par le concepteur de la ligne.

Share this post


Link to post
Share on other sites
pierreg    945

Oui, ce sont les scripts de la signalisation qui ont l'air de "plomber" le fps.

A+

PierreG

Share this post


Link to post
Share on other sites
mayday2233    111

Salut tout le monde,

 

Je déterre un peu le sujet :) .

 

Je me suis amusé à adoucir les pentes entre Paris nord et Lille Flandres et ça rend le trajet nettement plus sympa :) .

 

PierreG, tu penses que le problème vient des scripts de signalisation.

 

J'aimerais bien essayer de creuser un peu plus (je suis absolument pas compétent :D , mais c'est l'occasion d'apprendre).

 

En parcourant plusieurs forums j'ai bien vu que ça a l'air compliqué.

 

Néanmoins j'ai plusieurs questions auxquelles vous pourrez peut-être répondre:

 

1) Comment fait on pour accéder aux scripts de signalisation d'une ligne?

 

2)@ PierreG, chez moi je ne constate pas de chute de fps à l'approche d'un signal, mais plutôt une moyenne de fps basse entre 20 et 30 selon les endroits.

Un problème de script de signalisation peut il entrainer un faible fps sur toute la ligne même si on a aucun signal en vue?

 

3)La signalisation sur la ligne ne semble pas opérationnelle, (par exemple, sur la vidéo que j'avais postée j'ai du grillé plusieurs feux :D , alors que j'étais tout seul) , il me semble que c'est le cas aussi dans les scénarios fournis avec la ligne.

 

Est ce dû au fait que l'auteur a utilisé plusieurs règles de voie différentes (ce qui n'est pas conseillé, d'après ce que j'ai pu lire sur le forum) ou justement le problème de script? Ou les deux :D ?

 

4) La signalisation de la ligne vient du site il me semble, si j'ai bien compris un panneau de signalisation comprend l'objet décor (le panneau ou le feu) + le script qui va provoquer l'interaction avec le train.

 

Est ce qu'un panneau ou feu de signalisation a un script standard? Ou le créateur de ligne qui s'en sert modifie ensuite le script pour arriver à la situation qu'il souhaite?

 

 

Bonne soirée à tous

Share this post


Link to post
Share on other sites
mayday2233    111

En faisant des tests, j'ai remarqué que TS prenait quand même en compte certains paramètres du panneau de contrôle nvidia.

 

notamment le filtre anisotropique , en x16 affine encore plus l'image, effectivement le jeu ne prend pas en compte antialiasing mode.

 

Par contre en activant le MFAA j'ai gagné une moyenne de 4fps sur la ligne

 

résultats : j'ai 26 fps de moyenne aux abords de moyenne et entre 30 et 33 fps sur le reste de la ligne. ( avec l'ICE 3, j'ai 2-3fps en moins avec le tgv renove 2 de pml3 et moins de fluidité)

 

tous les détails à fond , vsync + triple buffer on , résolution 4k.

 

précision : en quickdrive sans AI ( j'ai tenté de mettre des trains statiques, ça fait chuter le fps)

 

je suis content car bonne fluidité sur la LGV.

 

Et là où ça devient intéressant,

 

J'ai eu un bug qui m'arrive 2 fois par an, mon SSD se déconnecte sans raison, mais le jeu n'a pas planté.

 

Je me suis retrouvé sans décor, il restait seulement le train, la voie et la SIGNALISATION, et là surprise! le fps n'est pas monté plus haut que 35-36 fps ( je suis limité à 60), donc Pierre G a sûrement raison, le problème de FPS vient soit

 

des voies, soit des scripts de signalisation qui plombent la ligne. Mais pas d'un asset du décor.

Share this post


Link to post
Share on other sites
henrion    97

Il serait surprenant que les scripts de la signalisation plombent les fps. Ce sont des fichiers texte qui sont lus en une fraction de seconde et le changement des feux est immédiat. Quand j'ai travaillé sur les scripts de la LGV qui sont très longs, je n'ai jamais constaté de chute de fps.Par contre je travaille avec uniquement la voie et la signalisation sans d'autres assets.

Share this post


Link to post
Share on other sites
mayday2233    111

Merci henrion pour la précision :)

 

Cela devient compliqué de trouver ce qui coince, peut être le type de voie utilisée? (surtout du concretie 001)

 

@Pierre G, comment as tu fait pour changer la taille des texture de voie et/ou remplacer le type de voie?

 

l'incohérence des règles de voies sur la ligne pourrait il expliquer le problème?

 

On arrivera peut être un jour à debugger la ligne :D

Share this post


Link to post
Share on other sites
GerardS    305

Bonjour.
Je pense que le décor intervient pour le taux des fps
Dans l'exemple si dessous, la météo également.
Météo défaut = 408fps
Météo : temps clair = 279fps.
Tout à fait surprenant.
Cordialement
Geluc

post-338-0-01964900-1457976499.jpg

post-338-0-88942600-1457976500.jpg

Share this post


Link to post
Share on other sites
mayday2233    111

Merci Geluc de prendre le temps de regarder :)

 

Je suis d'accord avec toi le décor, c'est ce qui parait le plus logique.

 

Mais ça m'a fait penser à un autre détail qui m'a interpellé, c'est la différence de taux de fps entre l'éditeur du monde et celui de scénario.

 

le fps de l'éditeur de scénario correspond quasiment au fps dans le jeu, celui de l'éditeur du monde au fps rêvé :D .

 

quelques screens comparatifs gare du nord et une zone sans décor à côté de la gare du nord:

 

éditeur de scénario:

 

post-7390-0-09250100-1457990656_thumb.jpg

19fps

 

post-7390-0-62808100-1457990706_thumb.jpg

20fps

 

post-7390-0-63093700-1457990718_thumb.jpg

28fps

 

éditeur du monde

 

post-7390-0-33583500-1457990855_thumb.jpg

40 fps

 

post-7390-0-86062200-1457990875_thumb.jpg

33 fps

 

post-7390-0-33066400-1457990891_thumb.jpg

61 fps

 

C'est pour ça que je ne suis pas sûr que ce soit lié à un asset de décor car en éditeur monde sur une zone sans asset je suis à 60fps, alors qu'en éditeur scénario sur la même zone seulement 30, étrange

 

 

j'ai remarqué ça en bidouillant un peu la ligne :D

 

Les créateurs de ligne et de scénarios ont peut être une idée ;) , qu 'en pensez vous? est ce normal?

 

Bonne soirée

Edited by mayday2233

Share this post


Link to post
Share on other sites
cc72077    190

Le premier qui trouve gagne ...

 

Toute notre reconnaissance !

Share this post


Link to post
Share on other sites
pierreg    945

@mayday2233 : c'est un sujet que je n'ai pas regardé depuis janvier dernier.

En recherchant traces de mes essais qui ont essentiellement eu lieu Gare du Nord, voilà pourquoi j'ai suspecté les scripts des signaux:

-réduction des textures des assets Gare du Nord : pas de changement,

-changement des voies en voies ordinaires Kuju (substitution des règles et des tracks dans Tracks.bin avec Rw_tools) : pas de changement

-dans le sélecteur d'assets/auteurs de l'éditeur de scénario, suppression de la majorité des assets de scenery : pas de changement

-dans le dossier "assets" de RailWorks, suppression du dossier des signaux (en l'occurrence "Terlor") : passage de 21fps à 40-50fps mais plus de signaux...

 

Je ne suspecte pas la qualité des signaux de TerLor mais peut-être leur mise en oeuvre ? Car il y en a beaucoup en Gare du Nord et en regardant quelques scripts je me suis posé la question. Je n'en sais pas plus à moins que la charge graphique induite soit également importante : c'est vrai que beaucoup de textures 1024x1024 pour des signaux, c'est peut-être un peu luxueux ?

A+

PierreG

 

 

 

 

 

Share this post


Link to post
Share on other sites
mayday2233    111

@PierreG

 

TU ES UN BOSS!!! :D

 

Effectivement j'ai viré le dossier Terlor dans les assets.

 

Je suis entrain de tester, je viens partir de lille flandres direction paris, 45-50fps à lille flandres et 60 fps 1km après la sortie de la gare (Vsync activée + 60fps limit + tous les détails à fond)

 

Ce qui m'intrigue, c'est qu'on a pas les signaux de terlor sur la LGV et que malgré tout le fps est impacté sur toute la ligne avec les assets de terlor.

 

En tout cas un grand merci PierreG, pour le moment je me passerai de la signalisation qui de plus, ne me paraissait pas fonctionnelle, et de toute façon la LGV ne comporte pas de TVM me semble-t-il.

 

Script? surcharge graphique? Je n'en sais rien, je n'ai pas la compétence

 

 

Mais en tout cas tu as fait un heureux ce soir :D :D :D :D

Edited by mayday2233

Share this post


Link to post
Share on other sites
mayday2233    111

Test concluant!

 

De gonesse à l'entrée gare du nord 60fps.

 

A l'entrée gare du nord 55fps.

 

Dans la gare 45 fps.

Share this post


Link to post
Share on other sites

×