Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
juju49

Exporter IGS - BRIAGE (Blender 2.79.7)

Recommended Posts

juju49    355

Bonjour à tous!

Aujourd'hui est un jour très cool B) . Enfin surtout pour les utilisateur de Blender qui exportent vers TS2016 ! Je vous présente donc ici la mouture v2.2.1!

http://jujumatic.free.fr/screenshot%20facility/TS20XX/IGexp1.swf

 

-----------------------------------------------------------------------------------

 

 

BRIAGE Disponible ICI

 

-----------------------------------------------------------------------------------

Ça fait plusieurs mois (novembre 2015) que j'ai bossé sur l'exporter de Dom107 pour lui donner une interface et étendre ses fonctions. J'ai appris le python sur le tas; et j'ai ajouter ça:

  • Interfaces:
    • UI pour les matériaux (properties>material)
    • UI pour les textures (properties>textures)
    • UI pour les options d'export IGS (properties>scene)
    • UI pour les options d'export IA (properties>scene)
    • UI pour les rapports d'erreurs courantes (pop-ups + console system)
    • UI pour la sélection du chemin de TS (user prefs>addons)
  • Nouvelles fonctionnalités
    • Export des Vetex Weights et Armatures (IGS et IA)
    • Export des Vertex Colors
    • Export de la couleur de l'objet
    • Les textures peuvent être placées dans des répertoire frères ou cousins ou plus
    • Les chemins des textures peuvent être redirigés individuellement à l'export
    • Conversion automatique des textes, courbes, meta et surfaces à condition qu'ils aient 1 matériel d'assigné
    • Contrôle du nombre de slots à l'export pour tous les shaders
    • Export des Snap-points
  • Options des matériaux
    • Liste des shaders de TS importée dynamiquement
    • des shaders hors liste peuvent être utilisés (comme le TrainBump.fx)
    • rétrocompatibilité avec l'ancien système de shaders
    • Options "Unlit" et "Pre-DPP" disponibles
    • Option "UV scroll" disponible
  • Options des textures
    • Remplacement au cas par cas des chemins de texture à l'export
  • Options à l'export
    • Elles sont sauvegardées par scene (permet plusieurs options d'IGS dans un seul *.blend en fonction des scènes; très pratique à l'export d'objet comprenant des parties déformables!)

-----------------------------------------------------------------------------------
L'exporter étant presque terminé, je cherche des testeurs et/ou des volontaires pour réécrire le manuel. N'hésitez pas à vous proposer ici ou par MP.
Aussi, toutes les critiques, questionnements et affirmations sont les bienvenues évidemment ;) !

-----------------------------------------------------------------------------------

MàJ 2.5: avec manuel en Français!

à plus!
Julian M.

Edited by juju49
nom du sujet màj, liens mort supprimés
  • Like 2

Share this post


Link to post
Share on other sites
juju49    355

Bonsoir!

 

L'export des Snap points est terminé; le résultat dans TS:

 

railwo41.jpg

 

railwo39.jpg

 

railwo42.jpg

 

railwo44.jpg

 

railwo40.jpg

 

railwo43.jpg

 

à plus!

Julian M.

  • Like 2

Share this post


Link to post
Share on other sites
Erakis    113

Salut Juju,

 

Superbe boulot, bravo ! L'intégration des shaders et des UVArguments à l'UI était dans mes ambitions à une époque, mais c'est passé au second plan étant donné le rapport bénéfice/temps passé désavantageux en ce qui me concerne.

 

Et je vois que tu es allé bien plus loin.

 

Encore bravo pour faire monter en maturité ce merveilleux petit plugin !

 

A+

 

PS : si tu manques de testeurs et/ou de rédacteurs je peux te prêter main forte, mais sache que je ne suis pas très disponible cette semaine et la suivante (déménagement).

  • Like 1

Share this post


Link to post
Share on other sites
pierreg    1,233

Excellent Juju ! Merci :)

Je veux bien essayer ce très utile complément au travail de Dom (mais dans la mesure de mes compétences).

Et même, j'ai l'impression que tu as prévu pas mal de cas, car je vois l'option des textures animées....

A+

PierreG

 

 

  • Like 1

Share this post


Link to post
Share on other sites
zkiko    69

Bonjour juju et bonjour à tous,

 

Super ton amélioration du script d'exportation; avant tout merci :D:):wub:

 

Je me propose de tester ton export si tu veux, j'ai quelques créations dans mes cartons...

 

Une question me taraude; à tu rendu possible le view-facing avec le matériel AddTex ?

 

Tiens-moi au courant.

 

Merci d'avance.

 

Amicalement zkiko.

  • Like 1

Share this post


Link to post
Share on other sites
juju49    355

Salut!

 

Une question me taraude; à tu rendu possible le view-facing avec le matériel AddTex ?

Si quelqu'un sait le faire avec 3DS max et me passe l'igs terminé, je peux fixer le problème. Mais pour l'instant, ce n'est pas encore le cas!

 

D'ailleurs, j'hésite à corriger le bug des objets qui disparaissent si l'origine de l'objet n'est pas compris dans la bounding box. à la place je met des blocs invisibles ou juste un triangle invisible donc bon... eh puis il parait que les autres exporters dont pareils... .... bon.

 

à plus!

Julian M.

Share this post


Link to post
Share on other sites
juju49    355

Bonsoir à tous,

 

BRIAGE est en ligne ICI.

 

Je remercie tout ceux qui ont été de l'aventure. Pour l'instant, il n'y a pas de manuel en français, j'encourage tout projet de traduction car j'ai pas la foi de me remettre là dessus à près avoir totalisé près de 70 pages de manuel revu en anglais.

 

à plus,

Julian M.

  • Like 2

Share this post


Link to post
Share on other sites

Bonsoir.

 

J'essaye d'exporter un format IGS depuis Blender, j'ai un message d'erreur :

 

Traceback (most recent call last):
File "H:\SteamLibrary\steamapps\common\Blender\2.78\scripts\addons\BRIAGE_DEV\Bl_data.py", line 453, in execute
SystemError: Parent module 'BRIAGE' not loaded, cannot perform relative import
location: <unknown location>:-1
Quelqu'un peut-il m'aider ?
Ch.

Share this post


Link to post
Share on other sites
juju49    355

Bonsoir!

 

Désolé, j'ai fais une boulette à la compilation en voulant aller trop vite, je refais ça et publie autour de 19h!

 

Pouah! j'ai encore découvert une série de bugs donc ça va prendre un peu de temps

 

à plus, Julian M.

Edited by juju49

Share this post


Link to post
Share on other sites

Bonsoir.

 

Ok, j'attends avec impatience le nouveau Briage.

 

En fait, l'export fonctionne maintenant mais je n'ai pas de fichier Log et il me demande toujours la texture en ACE.

Même en convertissant la texture en ACE avec RW_tools, j'ai un erreur.

 

J'y suis presque.....

 

Ch.

Share this post


Link to post
Share on other sites

Il est 20h13, je reprends le dossier.

 

Ch.

 

Après avoir réessayer, rien ne va....

 

Je suis encore une fois bloqué.

Edited by christiandard

Share this post


Link to post
Share on other sites
juju49    355

Laissez tomber pour ce soir ou téléchargez la version précédente en attendant demain. J'ai rencontré d'autres bugs en cherchant le votre et Blender me fais des siennes... j'espère que ce sera bon pour demain!

Share this post


Link to post
Share on other sites

Bonjour.

 

Je ne sais pas si le "paquet" est opérationnel maintenant ?

 

Je continue de modéliser pour me faire la main mais j'aimerais bien voir une de mes productions dans le jeu.

Tout ceci afin de faire une ligne bien belge.

 

Ch.

Share this post


Link to post
Share on other sites
juju49    355

le paquet n'est toujours pas opérationnel, j'ai beaucoup de travail scolaire à cause de la fin du trimestre approchante et peu de temps. J'espère regler le problème le problème le week-end prochain. En attendant, la version précédante marche pour les objets sans shaders à plusieurs UVmap

Edited by juju49

Share this post


Link to post
Share on other sites
juju49    355

Bonjour!

 

ça y est, j'ai mis la nouvelle version en ligne, le paquet est donc censé être opérationnel. désolé pour la gène occasionnée.

 

à plus,

Julian M.

  • Like 3

Share this post


Link to post
Share on other sites
Giftaddict    7

Salut!

 

Merci pour le boulot effectué! J'ai un problème au moment de l'export, j'obtiens ce message d'erreur (déjà posté plus haut) :

 

yuoy.jpg

 

Le truc c'est que j'ai beau passé aux versions précédentes de l'IGS (2.77), le message revient toujours. Je me demande si c'est pas moi qui me suis planté quelque part parce que tout fonctionnait il y a encore quelques jours!

 

EDIT: le chemin semble être faux, je n'ai pas de partition H: sur mon pc^^

Edited by Giftaddict

Share this post


Link to post
Share on other sites
juju49    355

Bonjour!

 

C'est un bug que j'ai corrigé dans la nouvelle version postée il y a peu. cela arrivait quand la liste des objets se générait mal suite à une erreur de paramètres...

 

Il est possible que vous ayez fait une fausse manip lors de la mise à niveau:

  1. désinstaller les fichiers de BRIAGE
  2. Installez les nouveaux fichier selon votre méthode préférée.
  3. Vérifiez ensuite dans la console de Blender ("Window>Toggle System Console" dans le volet "information") le numéro de version de BRIAGE. cela doit être: "2.2.306".

EDIT: Un de mes amis à eu le même problème par Skype tout à l'heure et cela a réglé l'erreur. J'espère qu'il en sera de même pour vous.

 

à plus,

Julian M.

Edited by juju49

Share this post


Link to post
Share on other sites
Giftaddict    7

Merci pour les infos! C'est possible qu'il y aie eu un problème au moment de l'installation, je teste tout ça je redonne des nouvelles. En tous cas merci pour le plugin il est bien pratique!

Share this post


Link to post
Share on other sites
gat07    0

Bonjour,

Je viens d'installer BRIAGE dans Blender et j'ai un petit soucis au démarrage de Blender: il affiche un message d'erreur:

 

Blender.exe pas de disque

Il n'y a pas de disque dans le lecteur. Insérez in disque dans le lecteur H:.

Annuler Recommencer Continuer

 

 

Après avoir cliqué quelques fois sur les options pour annuler ou continuer, Blender se lance et là, plus de problème.

Si je supprime Briage des Addons, le phénomène ne se produit plus, si je le réinstalle, ça recommence.

Ceci avec la dernière version de Briage, et les versions 2.77 et 2.78b de Blender.( sous windows 10, 64 bits).

 

Même si ce n'est pas très gênant, si quelqu'un a une explication...... Merci

 

 

Share this post


Link to post
Share on other sites
gat07    0

J'ai dit que ce n'était pas très gênant mais en fait si: en voulant exporter le message réapparait et l'export IGS ne se fait pas, c'est même très gênant

 

Merci

Share this post


Link to post
Share on other sites
gat07    0

Pas besoin de réponse j'ai trouvé la faille: j'ai installé BRIAGE en suivant la seconde procédure du manuel en anglais, c'est à dire en l'installant via addons du menu "prefernces utilisateur" depuis le fichier ZIP, et maintenant plus de messages et export concluant.

 

Merci quand même

JL

Share this post


Link to post
Share on other sites
juju49    355

Bonsoir,

 

Il est vrai que les erreur d'installation posent problème.

 

une nouvelle mouture de l'exporteur est sortie et corrige un bug handicapant lors de l'export de plusieurs UVmaps.

 

voilà, à plus,

Julian M.

Share this post


Link to post
Share on other sites
gat07    0

Bonsoir,

 

Merci du renseignement, je vais voir cette nouvelle mouture. Quoi que maintenant les problèmes sont avec Blender, mais c'est pas le logiciel, c'est le bonhomme et là il n'y a que moi qui puisse y faire quelque chose.

à plus

 

JL Gateau

Share this post


Link to post
Share on other sites

×