Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
  • Who's Online   1 Member, 0 Anonymous, 96 Guests (See full list)

  • Recently Browsing   0 members

    No registered users viewing this page.

Recommended Posts

Michael Blackbird    4,022

Salut,

Ca fait longtemps que j'essaie de créer des lofts à partir de 3D Crafter, mais impossible d'obtenir quelque chose de visible. Dans la plupart des cas, comme l'exemple ci-après, je peux dérouler le loft, et le déplacer, mais rien n'est visible.

J'ai pourtant lu plusieurs tuto.... vu des exemples, mais je dois rater un truc. Si quelqu'un pouvez me dire s'il voit un truc qui cloche, ça pourrait me débloquer. Et ce n'est pas les idées de lofts qui ma manquent. Entre les quais, les murs, les talus, les tunnels....

J'ai pris des captures des étapes importantes. L'exemple de mon essai est un simple quai avec 2 plans.

D'abord la vue du quai dans Sketchup

1.thumb.JPG.0f5f0a05b1da39e589b60d47f42113b8.JPG

Puis dans 3D Crafter avec la structure à droite. Les points de début sont bien en 0 alignés sur l'axe rouge et le profil est dans la direction de l'axe vert. J'avais 2 pivots après exportation qui sortaient de je ne sais où. Je les ai déplacés en 0;0;0.

2.thumb.JPG.5b8390e90a04ec24c8ec6eec1c279c1f.JPG

Les propriétés du material (à noter que si je n'ai pas le .fx pour le shader, j'ai une erreur dans TS, alors que je n'ai d'habitude pas besoin)

3.thumb.JPG.afee9013a6d704c5d32f6b553dc10c70.JPG

Et les paramètres du blueprint

4.thumb.JPG.a4580cf5d78db6b2786b1e75bf980da6.JPG

Edited by Michael Blackbird

Share this post


Link to post
Share on other sites
pierreg    3,425

Bonjour Michaël,

"Vieux" problème en effet ...!

En principe, "Population frequency" est la longueur de ton élément de base.  "0" fonctionne parfois mais essaye quand même une vraie valeur en mètres si tout le reste est correct (tous les points du profil à 0 en Y en particulier).

A+

PierreG

 

 

Edited by pierreg
  • Thanks 1

Share this post


Link to post
Share on other sites
Michael Blackbird    4,022

Merci Pierre.

J'ai essayé avec Population freq à 6.6 comme la longueur de l'extrusion de mon modèle, mais toujours rien. En essayant de mesurer la position exacte dans Sketchup, j'ai constaté que j'avais 2 segments pour une ligne. J'ai refait ce plan et toujours pareil.

Je ne suis pas trop étonné. De ce que je comprends pour Population Frequency, c'est la distance de répétition du middle geometry. Distance entre poteaux par exemple.

Citation

Population Geometry

As with other lofts, by specifying the modular viaduct piece asset in the middle geometry field in the loft section blueprint, this asset will be populated along the loft (which is invisible in this case) at a distance specified as the population frequency.

Sinon, je pense bien être à 0;0;0. 3D Crafter semble le confirmer :

5.JPG.8d511fe4f4c9d4da551bbc7881add6ff.JPG

Un truc étrange d'ailleurs. J'ai essayé de répéter un objet dans le middle geometry et je ne voyais pas non plus. J'ai encore essayé et toujours rien.... :huh:

Share this post


Link to post
Share on other sites
Michael Blackbird    4,022

Est-ce que je suis sur les bons plans ?

J'ai vu que Sur Blender et/ou 3DS Max, Z était l'axe de la hauteur. Ce qui me parait normal. Hors ici en voyant les limites de mon objet (image précédente), je vois que c'est Y l'axe vertical. Pourtant tous les objets que j'exporte à partir de 3D Crafter sont orientés de la même façon et sont corrects dans TS.

Je vais faire un essai de rotation au cas où.

EDIT

C'est pareil.

Edited by Michael Blackbird

Share this post


Link to post
Share on other sites
pierreg    3,425

Quand j'ai écrit "tous les points du profil à 0 en Y", c'est une erreur : c'est tous les Z du profil qui doivent être à 0.0 exactement. OY est la verticale et OZ est orienté à l'horizontale "droit devant" vers l'horizon !

  • Thanks 1

Share this post


Link to post
Share on other sites
Michael Blackbird    4,022

Il me semble que c'est bien ce que j'ai dans le premier exemple. J'ai bien le profil établit le long de l'axe OX et les 2 plans s'étalent vers l'horizon suivant OY. Tu peux le voir sur la capture.

Je viens de reprendre ton chemin01 dont tu m'avais fait passer les fichiers. J'ai l'impression que le 3DC fait avec ta version 3D Canvas subit des modifs lors de l'ouverture avec 3D Crafter et se retrouve décalé.

La position mini est X=1.5 Y=0.09 et Z=8.0. Ce qui explique aussi que lorsque j'ai voulu l'utiliser pour refaire un igs, ça n'a pas fonctionné non plus.

En revanche je remarque que tu n'as pas de MAIN dans la structure, mais c'est peut-être à cause de la conversion du 3DC par 3D Crafter. En tous cas, j'ai essayé et ça ne marche pas non plus.

Share this post


Link to post
Share on other sites
Roro45    668

Salut,

Je ne suis pas à la maison mais dès que je rentre, je t'explique.

De mémoire, en attendant.

  • X,Y,Z à 0.
  • L'objet dans la partie haute vue dessus.
  • Le nom main, c'est pour MSTS. Dans Rail sim, tu le nomes comme tu veux.

Roger.

 

Edited by Roro45
  • Thanks 1

Share this post


Link to post
Share on other sites
Michael Blackbird    4,022

Salut Roger,

Merci pour tes premières infos. OK pour MAIN.

Ceux qui m'avaient dit que c'était important sont d'illustres créateurs avec des années d'expérience (ça veut pas dire vieux). :D

Share this post


Link to post
Share on other sites
fred24    185

Je ne sais pas si ça peut t aider, dans 3ds l orientation d un talus avec son fossé:

 

Image2.thumb.jpg.d76a390bc55098aec9e435fae153df0a.jpg

  • Thanks 1

Share this post


Link to post
Share on other sites
Michael Blackbird    4,022

Merci Fred. ;)

C'est bien ce que j'ai compris et ce que je pense avoir fait.

Je crois vraiment que c'est un pb de hiérarchie des noeuds dans 3D Crafter. Et malheureusement, peu de créateurs l'utilisent. De plus il semble y avoir des différences avec 3D Canvas que d'autres utilisent ici (PierreG par exemple).

Mais on va trouver. :D

Share this post


Link to post
Share on other sites
Roro45    668

Salut,

L'objet doit être posé comme le montre Fred.

Pour ma part, j'utilise le shader "loftTexdifftrans.fx"

Quai.thumb.jpg.d7b90c9a222808a2b37d3bcf45ea670a.jpg

La texture doit être dans la même orientation que l'objet.

Mise à part ça, je ne vois rien d'autre.

Roger.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Michael Blackbird    4,022

Bonjour,

Merci pour ta réponse Roger.

Donc tu ne coches pas Center quand tu importes le fichier dans 3DC ? A moins que tu crées le modèle directement dans 3DC.

Tu pourrais montrer la structure de l'objet (l’icône pyramide rouge de la fenêtre propriétés) stp ?

loftTexdifftrans.fx pour les transparences, mais ça ne doit pas gêner d'utiliser loftTexdiff.fx .

En tous cas, j'ai essayé sans centrer l'objet à l'importation et c'est pareil. Mon objet est bien dessiné dans Sketchup comme le montre Fred.

La position dans Sketchup :

quai.thumb.JPG.7a6302dac8340bd913f80a145c6068cc.JPG

Et la texture :

62d3c7a9c5ef0_quaiterrenouveau6mx60cm.thumb.jpg.a5aa3b789aa7140f6ebba24ed1605ab0.jpg

Je me rends compte qu'il y a une rotation de 180°. Je vais refaire un essai...

EDIT : pareil...

Edited by Michael Blackbird

Share this post


Link to post
Share on other sites
Roro45    668

Salut Michael ,

Envoie moi ton fichier 3DC avec la texture par mail. <Modération : email supprimé>

Roger

Edited by Erakis
Suppression de l'email pour la santé de la boîte mail de Roger, en espérant être passé avant les robots...

Share this post


Link to post
Share on other sites
Michael Blackbird    4,022

Salut Roger,

Je t'envoie ça ce soir en rentrant. Merci ! :D

Il faut d'ailleurs que je réponde à Pierre qui a essayé mais avec 3D Canvas qui n'est pas compatible avec les 3DC généré par 3D Crafter 10.2 (c'était prévu). :unsure:

Share this post


Link to post
Share on other sites

×