Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
amename

BluePrint incomplet

Recommended Posts

amename    2

Bonjour à tous

 

Lorsque je suis passé de RS à RW, j'ai copié les dossiers et fichiers comme indiqué dans ce forum.

 

Ma ligne à été transférée convenablement et depuis je continu à l'agrandir.

 

Lorsque j'ouvre le BluePrint, il ne s'affiche pas entièrement. ( rien dans la partie droite : voir photo1 ) donc je ne peut le modifier.

 

http://www.monalbum.fr/Photo-74KRQTQZ-D.jpg

 

Par contre ( voir la deuxième phote ) s'affiche ce Blueprint d'une façon différente.

 

http://www.monalbum.fr/Photo-7MK73TUX-D.jpg

 

Pourriez-vous m'en donner les raisons. Peut être une mauvaise transmission???

 

Merci d'avance

 

Cordialement

 

M.M.

Share this post


Link to post
Share on other sites
al60    199

Bonsoir,

 

Je remonte ce topic car j'ai le même problème qu'Amename.

Si quelqu'un avait une idée ??? :rolleyes:

 

Merci

Share this post


Link to post
Share on other sites
orangina75    83

Il y a RW_tools qui permet de passer proprement une route issue de rail simulator vers railworks (gratuit pendant 21 jours je crois, puis quelques Livres Sterling par la suite). Logiciel indispensable.

Share this post


Link to post
Share on other sites
amename    2

Bonsoir à tous

 

Merci orangina75 pour ta réponse.

 

J'ai téléchargé TW_Tools full pour 21 jours et même après l'avoir affiché en français, je ne comprend toujours pas comment transférer une route de RS vers RW.

 

Serait-il possible de m'indiquer la marche à suivre.???

 

Merci d'avance

 

Cordialement

 

M.M.

Share this post


Link to post
Share on other sites
Erakis    123

Bonsoir,

 

Attention, car si tous les blueprints sont effectivement des fichiers au format XML, l'inverse n'est pas vrai ! Les *.xml obtenus par conversion des fichiers *.bin au moyen du programme serz.exe ne sont pas des blueprints, tandis que ceux crées depuis le Blueprint Editor en sont (par définition). La structure et la syntaxe de ces 2 types de *.xml n'est pas la même, bien que les informations qu'ils contiennent peuvent être parfaitement identiques.

 

J'ai l'impression que le *.xml montré sur la capture d'écran est un *.xml de règle de voie (track rule) issu de la conversion d'un *.bin provenant du dossier Assets. Me trompé-je ?

Edited by Erakis

Share this post


Link to post
Share on other sites
JML    17

Bonsoir,

 

Attention, car si tous les blueprints sont effectivement des fichiers au format XML, l'inverse n'est pas vrai ! Les *.xml obtenus par conversion des fichiers *.bin au moyen du programme serz.exe ne sont pas des blueprints, tandis que ceux crées depuis le Blueprint Editor en sont (par définition). La structure et la syntaxe de ces 2 types de *.xml n'est pas la même, bien que les informations qu'ils contiennent peuvent être parfaitement identiques.

 

J'ai l'impression que le *.xml montré sur la capture d'écran est un *.xml de règle de voie (track rule) issu de la conversion d'un *.bin provenant du dossier Assets. Me trompé-je ?

 

Non, Erakis, tu ne te trompe pas,( je suppose que tu parles du problème de règle de voie de Spud) il sagit bien du .xml venant des assets, il comporte toute les données pour reconstitué la source mais il faut le faire manuellement.

 

A+

Share this post


Link to post
Share on other sites
Erakis    123

Hello !

 

( je suppose que tu parles du problème de règle de voie de Spud)

Je parle du problème d'Amename, mais il y a effectivement une connexion avec le problème de Spud dans la mesure où, lorsque des voies ont été posées dans le cadre d'une certaine règle (d'un certain "track rules blueprint"), les modifications ultérieures de la règle de voie n'impactera pas la voie déjà posée. (A moins d'une manip en cours de test par Spud, mais qui ne pourra de toute façon pas résoudre des problèmes tels que celui de l'écartement a priori.)

 

Mais dans tout ça, je ne comprends pas dans quelle mesure le problème viendrait du transfert de RS vers RW. Je pense qu'amename et al60 devraient nous donner plus de détails sur leur problème, si ce qui a été déjà évoqué précédemment ne répond pas à leurs interrogations.

 

Sur le reste, JML, nous sommes en phase.

Edited by Erakis

Share this post


Link to post
Share on other sites
al60    199

Hello !

Je parle du problème d'Amename, mais il y a effectivement une connexion avec le problème de Spud dans la mesure où, lorsque des voies ont été posées dans le cadre d'une certaine règle (d'un certain "track rules blueprint"), les modifications ultérieures de la règle de voie n'impactera pas la voie déjà posée. (A moins d'une manip en cours de test par Spud, mais qui ne pourra de toute façon pas résoudre des problèmes tels que celui de l'écartement a priori.)

 

Mais dans tout ça, je ne comprends pas dans quelle mesure le problème viendrait du transfert de RS vers RW. Je pense qu'amename et al60 devraient nous donner plus de détails sur leur problème, si ce qui a été déjà évoqué précédemment ne répond pas à leurs interrogations.

 

Sur le reste, JML, nous sommes en phase.

 

Bonjour à tous,

 

D'abord merci pour votre coup de main.

 

Je pense avoir compris mon problème.

 

Voilà, depuis le début je n'arrive pas a afficher les objets dans l'Asset Editor. et je ne comprenais pas pourquoi.

 

les manips que j'ai faites

 

Au début le répertoire Source est vide, j'ai donc copié le contenu du répertoire "Assets" dans ce répertoire. Mais rien n'apparaissait dans le bluprint éditor, je n'avais que des points d'interrogation en face des noms d'objets. :blink: ([attachmentid=2063])

 

Par contre lorsque j'ai créé mon modèle de ligne, l'"asset éditor" affichait bien l'ensemble des éléments.

 

[attachmentid=2064]

 

J'ai compris, grâce à Erakis, pourquoi les autres éléments ne s'affichaient pas. A cause de ces fichiers xml issus du répertoire Assets qui n'ont pas la même structures. ;)

 

 

 

Ma question : comment faire apparaitre les objets, qui ne sont pas de mon cru, dans l'asset éditor ? :D

 

Merci pour votre aide

 

Al60

 

PS ma Ligne en construction depuis 6 mois :

 

[attachmentid=2067]

 

[attachmentid=2068]

Share this post


Link to post
Share on other sites
Erakis    123

Bonjour !

 

Bonjour à tous,

 

D'abord merci pour votre coup de main.

 

Je pense avoir compris mon problème.

 

Voilà, depuis le début je n'arrive pas a afficher les objets dans l'Asset Editor. et je ne comprenais pas pourquoi.

 

les manips que j'ai faites

 

Au début le répertoire Source est vide, j'ai donc copié le contenu du répertoire "Assets" dans ce répertoire. Mais rien n'apparaissait dans le bluprint éditor, je n'avais que des points d'interrogation en face des noms d'objets. :blink: ([attachmentid=2063])

 

Par contre lorsque j'ai créé mon modèle de ligne, l'"asset éditor" affichait bien l'ensemble des éléments.

 

[attachmentid=2064]

 

J'ai compris, grâce à Erakis, pourquoi les autres éléments ne s'affichaient pas. A cause de ces fichiers xml issus du répertoire Assets qui n'ont pas la même structures. ;)

Je crois que maintenant tu peux enlever tous les fichiers du dossier Source qui sont issus du dossier Assets, ça risque de t'embrouiller plus qu'autre chose (à mon avis). Mais si les tout est mélangé dans le dossier Source ("vrais" blueprints et "faux" blueprints), ça pourrait prendre un peu de temps, surtout si tu avais déjà beaucoup de vrais blueprints à la base.

 

Ma question : comment faire apparaitre les objets, qui ne sont pas de mon cru, dans l'asset éditor ? :D

Un peut comme le "Depôt", je n'ai jamais trop compris ce qu'était cet Asset Editor... Pour moi, il y a 3 choses :

1) L'éditeur de lignes (World Editor, WE pour les intimes)

2) Le Blueprint Editor (BE pour les intimes)

3) Le visualiseur d'objets (c'est peut-être ça l'Asset Editor ?)

 

Du coup, peux-tu préciser ta question ?

 

PS ma Ligne en construction depuis 6 mois :

 

[attachmentid=2067]

 

[attachmentid=2068]

Excellent, une ligne de montagne, j'en salive d'avance !

Share this post


Link to post
Share on other sites
al60    199

c'est que là c'est un peu embrouillé :D

 

ma question c'est de pouvoir afficher le détail des objets (qui ne sont pas les miens) dans l'outil "Blueprints"("outils et Documents" du menu) car actuellement je n'ai que des points d'intérrogations en face de chaque objet. :(

 

Cordialement

 

Al60

Share this post


Link to post
Share on other sites
Erakis    123

OK je comprends mieux.

 

Le truc avec les créations (en tous genres) existantes, c'est que tu n'es pas obligé de les avoir dans ton dossier Source pour pouvoir t'en servir. (Sinon crois bien que je ne t'aurais pas suggéré d'y faire du ménage !)

 

Reprenons ta capture du BE :

 

[attachmentid=2064]

 

On voit bien que, par exemple, le "Spring sky blueprint" choisi est repris d'une création existante, en l'occurrence du contenu par défaut situé à l'emplacement \Kuju\RailSimulator\TimeOfDay. Voici comment raisonne le programme qui effectue l'exportation du blueprint lorsque tu appuies sur le bouton "Export" :

 

1) L'utilisateur me demande de prendre comme "Spring sky blueprint" le blueprint dont le chemin est \Source\Kuju\RailSimulator\TimeOfDay\Spring.xml.

2) Je ne trouve pas le fichier demandé (ou le fichier n'est pas un blueprint), je vais voir s'il existe un équivalent déjà exporté.

3) Je trouve effectivement le fichier \Assets\Kuju\RailSimulator\TimeOfDay\Spring.bin et l'utilise.

4) Je valide donc l'exportation et ne renvoie pas de message d'erreur.

 

Tu vois que tu peux très bien spécifier un blueprint qui n'existe pas dans le dossier Source à partir du moment où son équivalent en binaire existe dans le dossier Assets. (Mais attention, il faut bien spécifier l'extension *.xml, et non garder *.bin).

Edited by Erakis

Share this post


Link to post
Share on other sites
al60    199

Ok, ma lanterne s'éclaire. merci bien Erakis :D

 

Cordialement

 

Al60

Share this post


Link to post
Share on other sites
amename    2

Bonsoir à tous

 

Je reprend ce sujet et les discussions qui ont eu lieu, et que j'ai suivi avec attention. Hélas je n'ai toujours pas compris pourquoi la partie droite du BluePrint ne s'affiche pas malgré mes diverses manips suite à vos discussions.

 

Comme vous avez pu le constater dans un autre post dans ce chapitre de discussions generales, j'avais dans RW trois dossiers Source. J'en ai supprimé deux comme proposé par JML et cela n'a rien changé. En continuant les test, j'ai supprimé le troisième dossiers Source, qui se trouve dans " RW/ Steamapps/Common/RailWorks/...". A ce moment là il n'y avait plus rien dans la partie gauche du Blueprint. J'y ai remis quelques elements, par copier/coller depuis le dossier Asset; situé sous " RW/Steamapps/Common/RailWorks/.." à ce stade ces fichiers sont apparus dans le BluePrint à gauche, mais toujours rien à droite.

 

Pensant que l'export de RS vers RW s'était mal passé, j'ai de nouveau supprime les fichiers de l'Asset et de Source et j'ai recommencé avec le Gestionnaire d'Archives de RW d'intégrer de nouveau certains fichiers issus de téléchargement. Sans résultats d'ailleurs l'affichage d'un message d'erreur me disais qu' ils étaient déjà installé.

 

Je ne sais plus quoi penser. C'est certain, il faut pour que cela s'affiche a gauche dans le BluePrint que tout les fichiers de l'ASSET soit copiés, y compris toutes les routes personnelles, mais toujours rien à droite.

 

IL faudrait comme il est dit plus haut de différencier les extension XML réelles et modifiées, je ne vois pas comment voir la différence.

 

Je voudrais bien conserver l'affichage des BluePrints qui ont l'avantage de se corriger ou se modifier plus facilement que les fichiers XML avec le BlocNotes.

 

Excusez cette très longue explication, je pense qu'elle était, à mon avis nécessaire pour votre compréhension.

 

Si vous pensez y avoir trouvé une explication, je vous en remercie d'avance

 

Cordialement

 

M.M.

 

 

 

 

Share this post


Link to post
Share on other sites
Spud    137

Salut,

 

Je pense que tu ne peux afficher dans le Blueprint que des fichiers créé par ton BP editor... c'est le tour que j'ai eu avec ma règle de voie pour ma ligne, suite a pb sur RW j'ai réinstallé RW et suite à cela je n'ai plus accès à ma règle de voie, c'est pour cela que j'en recrée une autre.

 

Bye

Share this post


Link to post
Share on other sites
Erakis    123

Bonsoir Amename,

Je vais aller un peu dans les détails, il y aura peut-être plein de choses que tu connaissais déjà, mais « mieux vaux trop que panacée » ! tongue.gif

CITATION(amename @ 12 Apr 2010, 07:34 PM) 15312[/snapback]

Bonsoir à tous

Je reprend ce sujet et les discussions qui ont eu lieu, et que j'ai suivi avec attention. Hélas je n'ai toujours pas compris pourquoi la partie droite du BluePrint ne s'affiche pas malgré mes diverses manips suite à vos discussions.

Comme vous avez pu le constater dans un autre post dans ce chapitre de discussions generales, j'avais dans RW trois dossiers Source. J'en ai supprimé deux comme proposé par JML et cela n'a rien changé. En continuant les test, j'ai supprimé le troisième dossiers Source, qui se trouve dans " RW/ Steamapps/Common/RailWorks/...". A ce moment là il n'y avait plus rien dans la partie gauche du Blueprint. J'y ai remis quelques elements, par copier/coller depuis le dossier Asset; situé sous " RW/Steamapps/Common/RailWorks/.." à ce stade ces fichiers sont apparus dans le BluePrint à gauche, mais toujours rien à droite.

 


A la lecture de cette dernière phrase et au risque de me tromper, j'ai le sentiment que tu confonds le Blueprint Editor (éditeur de blueprints) avec les blueprints eux-mêmes. C'est vrai que le terme "blueprint" est difficilement traduisible en français, disons que c'est un genre de fiche à remplir qui va te permettre de "programmer" un aspect donné du jeu, chaque modèle de blueprint prenant en charge l'un de ces aspects. Ces blueprints sont des fichiers au format XML qui portent l'extension correspondante (*.xml donc).

Le Blueprint Editor (BE pour les intimes) est l'interface qui permet d'afficher et d'éditer n'importe quel blueprint de façon ergonomique pour les joueurs que nous sommes, ce qui nous évite ainsi de devoir manipuler le fichier *.xml directement avec un éditeur de texte (ce qui peut être vite pénible).

Comme tu l'as remarqué, l'arborescence qui apparaît à gauche dans le BE correspond exactement à ce qu'il y a dans le dossier Source de RailWorks. Ce dossier est un répertoire de travail : c'est dans ce dossier (plus précisément ses sous-dossiers) que tes créations sont en gestation. C'est dans le dossier Source (et uniquement ce dossier !) que vivent les blueprints.

Le dossier Assets, quant à lui, n'est pas un répertoire de travail, mais un répertoire de stockage où le jeu vient chercher toutes ses informations pour fonctionner. C'est dans ce dossier que se trouvent non seulement les créations téléchargées, mais aussi tes propres créations que tu as exportées via le Blueprint Editor. Pour ces derniers, tu retrouveras la même arborescence que dans le dossier Source, mais les fichiers qui s'y trouvent ne sont pas des blueprints, et ne sont donc pas susceptibles d'être édités !

(Note que j'utilise un code couleur : le vertcorrespond à la création et à l'édition de fichiers, tandis que le rougecorrespond au stockage et donc à des choses auxquelles on ne devrait pas toucher.)

L'exportation (effectuée depuis le BE lorsque l'on clique sur le bouton correspondant) correspond à l'opération qui consiste à créer dans le dossier Assets un fichier binaire (*.bin) construit à partir du blueprint (*.xml) situé quelque part dans le dossier Source. Cette opération aboutit également à la création dans le dossier Assets d'un fichier *.xml de même nom que le blueprint (lui aussi un *.xml) et le fichier *.bin. Ce *.xml du dossier Assets que j'appelle *.xml brut est parfaitement inutile au fonctionnement du jeu, et en plus on ne peut même pas l'éditer avec le Blueprint Editor après transfert dans le dossier Source ! En effet, je me permets d'auto-citer mon premier message (mais non je ne suis pas mégalo wink.gif ) :

CITATION(Erakis @ 9 Apr 2010, 09:42 PM) 15257[/snapback]

Attention, car si tous les blueprints sont effectivement des fichiers au format XML, l'inverse n'est pas vrai ! Les *.xml bruts obtenus par conversion des fichiers *.bin au moyen du programme serz.exe ne sont pas des blueprints, tandis que ceux crées depuis le Blueprint Editor en sont (par définition). La structure et la syntaxe de ces 2 types de *.xml n'est pas la même, bien que les informations qu'ils contiennent peuvent être parfaitement identiques.

 


Par conséquent, il est parfaitement inutile de transférer des fichiers du dossier Assetsvers le dossier Source, et vice versa !

Quelques précisions sur le fichier *.xml brut dans Assets. Malgré le double défaut de ne servir ni au fonctionnement du jeu ni à l'édition dans le BE, il peut néanmoins servir à apporter des corrections manuelles à l'aide d'un éditeur de texte, lorsqu'il n'y a pas d'autre solution. Le glisser-déposer du fichier *.xml brut sur une copie du programme serz.exe (qu'on trouve dans le dossier principal du jeu) va générer le fichier binaire correspondant (avec l'extension *.bin, donc), lequel pourra être exploité par le jeu.
L'autre utilité des *.xml bruts réside dans le modèle qu'ils peuvent constituer pour recréer "proprement" un blueprint (valeurs numériques, chemins vers d'autres blueprints, etc.) lorqu'on fait la rétro-ingénierie d'un fichier *.bin (toujours avec serz.exe qui permet également de faire l'opération *.bin -> *.xml). Je précise à nouveau qu'un blueprint et le *.xml brut correspondant contiennent les mêmes informations organisées de façon différente.

CITATION
Pensant que l'export de RS vers RW s'était mal passé, j'ai de nouveau supprime les fichiers de l'Asset et de Source et j'ai recommencé avec le Gestionnaire d'Archives de RW d'intégrer de nouveau certains fichiers issus de téléchargement. Sans résultats d'ailleurs l'affichage d'un message d'erreur me disais qu' ils étaient déjà installé.

 


Il faut à tout prix éviter de modifier manuellement le contenu du dossier Assetset de ses sous-dossiers, sauf cas exceptionnels (le transfert RS -> RW n'en est pas un) ! Par ailleurs les archives *.rpk (et *.rwp) ne mettent rien du tout dans le dossier Source ; il ne faut donc pas compter sur elles pour transférer ses blueprints de RS vers RW. Pour transférer vers RW une ligne faite sous RS ou une création qui a déjà été exportée avec les outils de RS, par contre, ça marche très bien.

CITATION
Je ne sais plus quoi penser. C'est certain, il faut pour que cela s'affiche a gauche dans le BluePrint que tout les fichiers de l'ASSET soit copiés, y compris toutes les routes personnelles, mais toujours rien à droite.

 


Si tu copies des fichiers issus du dossier Assetsdans le dossier Source (donc des *.bin et/ou des *.xml bruts), l'icône du fichier dans l'arborescence du Blueprint Editor va être un point d'interrogation, ce qui veut dire que le BE ne reconnaît pas ou ne sait pas traiter ce type de fichier. Si tu mets un fichier avec l'extension *.tartempion dans le dossier Source ou l'un de ses sous-dossiers, ça donnera exactement le même résultat.

Il faut abandonner cette façon de faire, c'est une voie sans issue.

CITATION
IL faudrait comme il est dit plus haut de différencier les extension XML réelles et modifiées, je ne vois pas comment voir la différence.

 


Les "mauvais" *.xml (*.xml bruts) sont dans Assetset doivent y rester. Les "bons" *.xml (les blueprints) sont dans Source et apparaissent dans le BE avec une icône qui représente autre chose qu'un point d'interrogation.

CITATION
Je voudrais bien conserver l'affichage des BluePrints qui ont l'avantage de se corriger ou se modifier plus facilement que les fichiers XML avec le BlocNotes.

 


Comme je te comprends !

J'aurais peut-être dû commencer par là, mais il est possible de créer un blueprint sur quasiment n'importe quel modèle depuis le BE, en cliquant avec le bouton droit sur le sous-dossier du dossier Source dans lequel on veut créer le blueprint et en choisissant New Blueprint.

CITATION
Excusez cette très longue explication, je pense qu'elle était, à mon avis nécessaire pour votre compréhension.

Si vous pensez y avoir trouvé une explication, je vous en remercie d'avance

Cordialement

M.M.

 



En espérant avoir aidé... Désolé s'il y a beaucoup de choses que tu savais déjà.

Edited by Erakis

Share this post


Link to post
Share on other sites
pml3    216

Bravo Erakis !

 

Excellentes explications sur les blueprint, les xml, et les répertoires du simu.

 

Je propose à Julien d'épingler le poste en tête du forum.

 

Patrick

Share this post


Link to post
Share on other sites
Erakis    123

Bonjour !

 

Parmi les pharaoniques (j'exagère à peine...) projets que j'ambitionne pour le wikiRail, je pensais notamment initier une "école du blueprint". Le bout de texte de ma précédente intervention, retravaillé, pourrait faire un premier chapitre ou une introduction honorable. Vu que j'y ai passé un peu de temps, ça serait l'occasion de graver ce laïus dans le marbre (ou plutôt dans le marshmallow vu qu'il s'agit d'un wiki).

 

Mais si on reste trois pelés et un tondu à participer, ça risque de ne pas avancer très vite (comme le reste, d'ailleurs)... :(

Edited by Erakis

Share this post


Link to post
Share on other sites
amename    2

Bonjour à tous

 

Un très grand merci a Erakis pour son excellent développement du BE; que j'ai enfin compris. En effet, de trouver en plusieurs endroit les même dossiers, avec la même extension, permettait la confusion.

 

En résumé, doit se trouver dans le dossier SOURCE, que des dossiers d'objets et de routes de MA création, le jeu allant chercher dans le dossier ASSETS les autres éléments nécessaire à son fonctionnement.

 

 

Merci encore, ainsi qu'a Julien pour avoir épinglé ce post, si indispensable pour les nouveaux venus. Il serait souhaitable, à mon avis, que cela soit transformé en un tuto

 

Amicalement

 

M.M.

Share this post


Link to post
Share on other sites
Jules31    44

Good luck camarade Erakis pour ton combat, en espérant qu'il soit vain.

 

Au fait, depuis quand es-tu devenu modérateur ? :huh:

Share this post


Link to post
Share on other sites
Ayro13    0

Bonjour,

 

Au risque d'être hors sujet, voici ma methode pour transferer une ligne éffectuée avec RailSimulator (RS) sous RailWorks (RW) sans utiliser RWTools (en attendant que RWtools prennent en compte la police de caractére francaise).

 

- Avec RSTools (freeware) faire un check route pour connaitre tous les assets utilisés et associés à votre ligne

 

- Supprimer les fichiers Blueprints.pak dans le dossier assets et sous-dossiers destiné à être copiés

 

- J'utilise le PackageManager de RS (apres mise à jour MK2 disponible sur le site de RS) et je réalise un fichier *.Rpk comprenant les assets de mes réalisations (ligne, objets....) et tous les assets associés crées par d'autres personnes (à l'exception des assets d'origine ceux de KUJU ou RDSL que l'on retrouve dans RW)

 

- Avec le Package Manager de RW, avec la touche "Install" ouvrir le fichier *.Rpk l'installation se fait sans problemes.

 

- Avec la touche Packager vous pouvez verifier que tous les assets sont bien installés

 

- Dans Tools§Docs nettoyer le Cache Blueprints

 

- Votre route est prête.

 

- Copiez les fichiers sources de RS dans RW en respectant l'arborescence.

 

- Copiez le dossier DEM pour le terrain

 

- RS avait été modifié pour reconnaitre toutes les polices de caractéres quelque soit la langue choisie, mais ce n'est pas le cas avec cette version de RW ou toutes les langues ont été dissociées. Si la présentation de votre ligne n'apparait quand vous ouvrez le jeu il suffit de placer votre fichier de presentation "description.html" dans le dossier suivant :

 

C:\Program Files\Steam\steamapps\common\railworks\Content\Routes\<<nomroutehexa>>\RouteInformation\FR\

 

Ca parait un peu compliqué mais ca marche en attendant la MAJ de RWTools.

 

Amitiés

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
Erakis    123

Re,

 

Bonjour à tous

 

Un très grand merci a Erakis pour son excellent développement du BE; que j'ai enfin compris. En effet, de trouver en plusieurs endroit les même dossiers, avec la même extension, permettait la confusion.

 

En résumé, doit se trouver dans le dossier SOURCE, que des dossiers d'objets et de routes de MA création, le jeu allant chercher dans le dossier ASSETS les autres éléments nécessaire à son fonctionnement.

Merci encore, ainsi qu'a Julien pour avoir épinglé ce post, si indispensable pour les nouveaux venus. Il serait souhaitable, à mon avis, que cela soit transformé en un tuto

 

Amicalement

 

M.M.

D'autres membres auraient sûrement pu t'aider de façon équivalente, mais hier soir j'avais tout le temps devant moi. :)

 

On va sans doute penser que je prêche pour ma paroisse, mais je pense que la meilleure place pour un tutoriel serait le wiki, dont la souplesse rend la création ou la modification d'articles très agréable (je trouve).

 

Good luck camarade Erakis pour ton combat, en espérant qu'il soit vain.

Vain ? J'espère que non, quand même ! :o

A moins que tu voulais dire "en espérant qu'ils soient vingt" [contributeurs réguliers au wiki], alors là oui, ce serait le pied !

 

 

Par ailleurs, merci Julien pour la confiance que tu m'accordes !

 

 

Bonjour,

 

Au risque d'être hors sujet, voici ma methode pour transferer une ligne éffectuée avec RailSimulator (RS) sous RailWorks (RW) sans utiliser RWTools (en attendant que RWtools prennent en compte la police de caractére francaise).

 

- Avec RSTools (freeware) faire un check route pour connaitre tous les assets utilisés et associés à votre ligne

 

- Supprimer les fichiers Blueprints.pak dans le dossier assets et sous-dossiers destiné à être copiés

 

- J'utilise le PackageManager de RS (apres mise à jour MK2 disponible sur le site de RS) et je réalise un fichier *.Rpk comprenant les assets de mes réalisations (ligne, objets....) et tous les assets associés crées par d'autres personnes (à l'exception des assets d'origine ceux de KUJU ou RDSL que l'on retrouve dans RW)

 

- Avec le Package Manager de RW, avec la touche "Install" ouvrir le fichier *.Rpk l'installation se fait sans problemes.

 

- Avec la touche Packager vous pouvez verifier que tous les assets sont bien installés

 

- Dans Tools§Docs nettoyer le Cache Blueprints

 

- Votre route est prête.

 

- Copiez les fichiers sources de RS dans RW en respectant l'arborescence.

 

- Copiez le dossier DEM pour le terrain

 

- RS avait été modifié pour reconnaitre toutes les polices de caractéres quelque soit la langue choisie, mais ce n'est pas le cas avec cette version de RW ou toutes les langues ont été dissociées. Si la présentation de votre ligne n'apparait quand vous ouvrez le jeu il suffit de placer votre fichier de presentation "description.html" dans le dossier suivant :

 

C:\Program Files\Steam\steamapps\common\railworks\Content\Routes\<<nomroutehexa>>\RouteInformation\FR\

 

Ca parait un peu compliqué mais ca marche en attendant la MAJ de RWTools.

 

Amitiés

Je crois que c'est effectivement la marche à suivre, si on veut procéder selon les règles de l'art !

 

J'essaie d'éviter d'utiliser RW Tools autant que faire se peut : c'est à mon avis une béquille dont on devrait pouvoir se passer dans toutes les situations. Ca me force aussi à résoudre les problèmes manuellement, ce qui m'aide à comprendre le fonctionnement de RW.

 

Par contre je reconnais que c'est bien pratique, notamment pour faire des repères de type LIGNE (SERIES) aux coordonnées plus précises : le Blueprint Editor tronque les valeurs des *.dcsv au 4e chiffre après la virgule, alors que RW Tools permet de conserver la précision des *.csv d'origine. Mais bon, avec RW Decal ça perd un peu de son intérêt...

Share this post


Link to post
Share on other sites
Spud    137

Salut,

 

C'est vrai que l'on pet dire un GRAND MERCI à Erakis et toutes les personnes ayant contribué au Wiki de RW car ça dépanne quand même un grand coup.

 

Merci et bon courage pour la suite, Je suis désolé mais je ne pourrai pas trop apporter ma contribution au wiki directement, peut être indirectement, ;) mais La construction de la ligne me prends déjà pas mal de temps j'en suis déjà à 642 heures et je pense qu'il m'en faudra presque autant pour la terminer donc....

 

 

Bye

Share this post


Link to post
Share on other sites
Erakis    123

Salut,

 

C'est vrai que l'on pet dire un GRAND MERCI à Erakis et toutes les personnes ayant contribué au Wiki de RW car ça dépanne quand même un grand coup.

 

Merci et bon courage pour la suite, Je suis désolé mais je ne pourrai pas trop apporter ma contribution au wiki directement, peut être indirectement, ;) mais La construction de la ligne me prends déjà pas mal de temps j'en suis déjà à 642 heures et je pense qu'il m'en faudra presque autant pour la terminer donc....

Bye

Un vraie ligne française, ça fait partie des choses qui ne peuvent que faire grossir notre communauté et amorcer un cercle vertueux de créations, donc je vois mal comment on pourrait t'en vouloir !

 

Mais je te rassure, à la vitesse où avance le wiki, je pense qu'il restera encore beaucoup de choses à y écrire lorsque tu en auras terminé ! ^_^

Share this post


Link to post
Share on other sites

×